The patch titled Subject: mm, slab: remove unnecessary unlikely() has been removed from the -mm tree. Its filename was mm-slab-remove-unnecessary-unlikely.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Yangtao Li <tiny.windzz@xxxxxxxxx> Subject: mm, slab: remove unnecessary unlikely() WARN_ON() already contains an unlikely(), so it's not necessary to use unlikely. Also change WARN_ON() back to WARN_ON_ONCE() to avoid potentially spamming dmesg with user-triggerable large allocations. [akpm@xxxxxxxxxxxxxxxxxxxx: s/WARN_ON/WARN_ON_ONCE/, per Vlastimil] Link: http://lkml.kernel.org/r/20181104125028.3572-1-tiny.windzz@xxxxxxxxx Signed-off-by: Yangtao Li <tiny.windzz@xxxxxxxxx> Acked-by: Vlastimil Babka <vbabka@xxxxxxx> Reviewed-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> Acked-by: David Rientjes <rientjes@xxxxxxxxxx> Cc: Christoph Lameter <cl@xxxxxxxxx> Cc: Pekka Enberg <penberg@xxxxxxxxxx> Cc: Joonsoo Kim <iamjoonsoo.kim@xxxxxxx> Cc: Dmitry Vyukov <dvyukov@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- --- a/mm/slab_common.c~mm-slab-remove-unnecessary-unlikely +++ a/mm/slab_common.c @@ -1029,10 +1029,8 @@ struct kmem_cache *kmalloc_slab(size_t s index = size_index[size_index_elem(size)]; } else { - if (unlikely(size > KMALLOC_MAX_CACHE_SIZE)) { - WARN_ON(1); + if (WARN_ON_ONCE(size > KMALLOC_MAX_CACHE_SIZE)) return NULL; - } index = fls(size - 1); } _ Patches currently in -mm which might be from tiny.windzz@xxxxxxxxx are async-remove-some-duplicated-includes.patch signal-remove-some-duplicated-includes.patch