The patch titled Subject: kasan: rename source files to reflect the new naming scheme has been added to the -mm tree. Its filename is kasan-rename-source-files-to-reflect-the-new-naming-scheme.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/kasan-rename-source-files-to-reflect-the-new-naming-scheme.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/kasan-rename-source-files-to-reflect-the-new-naming-scheme.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Andrey Konovalov <andreyknvl@xxxxxxxxxx> Subject: kasan: rename source files to reflect the new naming scheme We now have two KASAN modes: generic KASAN and tag-based KASAN. Rename kasan.c to generic.c to reflect that. Also rename kasan_init.c to init.c as it contains initialization code for both KASAN modes. Link: http://lkml.kernel.org/r/a6cd5acdc334d532754279a7d2d770e2be96419d.1543337629.git.andreyknvl@xxxxxxxxxx Signed-off-by: Andrey Konovalov <andreyknvl@xxxxxxxxxx> Reviewed-by: Andrey Ryabinin <aryabinin@xxxxxxxxxxxxx> Reviewed-by: Dmitry Vyukov <dvyukov@xxxxxxxxxx> Cc: Mark Rutland <mark.rutland@xxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- --- a/mm/kasan/Makefile~kasan-rename-source-files-to-reflect-the-new-naming-scheme +++ a/mm/kasan/Makefile @@ -1,14 +1,14 @@ # SPDX-License-Identifier: GPL-2.0 KASAN_SANITIZE := n UBSAN_SANITIZE_common.o := n -UBSAN_SANITIZE_kasan.o := n +UBSAN_SANITIZE_generic.o := n KCOV_INSTRUMENT := n -CFLAGS_REMOVE_kasan.o = -pg +CFLAGS_REMOVE_generic.o = -pg # Function splitter causes unnecessary splits in __asan_load1/__asan_store1 # see: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63533 CFLAGS_common.o := $(call cc-option, -fno-conserve-stack -fno-stack-protector) -CFLAGS_kasan.o := $(call cc-option, -fno-conserve-stack -fno-stack-protector) +CFLAGS_generic.o := $(call cc-option, -fno-conserve-stack -fno-stack-protector) -obj-y := common.o kasan.o report.o kasan_init.o quarantine.o +obj-y := common.o generic.o report.o init.o quarantine.o _ Patches currently in -mm which might be from andreyknvl@xxxxxxxxxx are kasan-mm-change-hooks-signatures.patch kasan-slub-handle-pointer-tags-in-early_kmem_cache_node_alloc.patch kasan-move-common-generic-and-tag-based-code-to-commonc.patch kasan-rename-source-files-to-reflect-the-new-naming-scheme.patch kasan-add-config_kasan_generic-and-config_kasan_sw_tags.patch kasan-arm64-adjust-shadow-size-for-tag-based-mode.patch kasan-rename-kasan_zero_page-to-kasan_early_shadow_page.patch kasan-initialize-shadow-to-0xff-for-tag-based-mode.patch arm64-move-untagged_addr-macro-from-uaccessh-to-memoryh.patch kasan-add-tag-related-helper-functions.patch kasan-arm64-untag-address-in-_virt_addr_is_linear.patch kasan-preassign-tags-to-objects-with-ctors-or-slab_typesafe_by_rcu.patch kasan-arm64-fix-up-fault-handling-logic.patch kasan-arm64-enable-top-byte-ignore-for-the-kernel.patch kasan-mm-perform-untagged-pointers-comparison-in-krealloc.patch kasan-split-out-generic_reportc-from-reportc.patch kasan-add-bug-reporting-routines-for-tag-based-mode.patch mm-move-obj_to_index-to-include-linux-slab_defh.patch kasan-add-hooks-implementation-for-tag-based-mode.patch kasan-arm64-add-brk-handler-for-inline-instrumentation.patch kasan-mm-arm64-tag-non-slab-memory-allocated-via-pagealloc.patch kasan-add-__must_check-annotations-to-kasan-hooks.patch kasan-arm64-select-have_arch_kasan_sw_tags.patch kasan-update-documentation.patch kasan-add-spdx-license-identifier-mark-to-source-files.patch