- almost all of the rest of MM - kasan updates - lots of procfs work - misc things - lib/ updates - checkpatch - rapidio - ipc/shm updates - the start of willy's XArray conversion 140 patches, based on f77cfbe6455a67d4e9b69f08f07fc62cd11b0674: Subject: mm: introduce NR_INDIRECTLY_RECLAIMABLE_BYTES Subject: mm: treat indirectly reclaimable memory as available in MemAvailable Subject: dcache: account external names as indirectly reclaimable memory Subject: mm: treat indirectly reclaimable memory as free in overcommit logic Subject: mm/vmscan: update stale comments Subject: mm/vmscan: remove redundant current_may_throttle() check Subject: mm/vmscan: don't change pgdat state on base of a single LRU list state Subject: mm/vmscan: don't mess with pgdat->flags in memcg reclaim Subject: mm, vmscan, tracing: use pointer to reclaim_stat struct in trace event Subject: mm/hmm: documentation editorial update to HMM documentation Subject: mm/hmm: fix header file if/else/endif maze Subject: mm/hmm: HMM should have a callback before MM is destroyed Subject: mm/hmm: unregister mmu_notifier when last HMM client quit Subject: mm/hmm: hmm_pfns_bad() was accessing wrong struct Subject: mm/hmm: use struct for hmm_vma_fault(), hmm_vma_get_pfns() parameters Subject: mm/hmm: remove HMM_PFN_READ flag and ignore peculiar architecture Subject: mm/hmm: use uint64_t for HMM pfn instead of defining hmm_pfn_t to ulong Subject: mm/hmm: cleanup special vma handling (VM_SPECIAL) Subject: mm/hmm: do not differentiate between empty entry or missing directory Subject: mm/hmm: rename HMM_PFN_DEVICE_UNADDRESSABLE to HMM_PFN_DEVICE_PRIVATE Subject: mm/hmm: move hmm_pfns_clear() closer to where it is used Subject: mm/hmm: factor out pte and pmd handling to simplify hmm_vma_walk_pmd() Subject: mm/hmm: change hmm_vma_fault() to allow write fault on page basis Subject: mm/hmm: use device driver encoding for HMM pfn Subject: mm/hmm.c: remove superfluous RCU protection around radix tree lookup Subject: mm/hmm: fix header file if/else/endif maze, again Subject: Documentation/vm/hmm.txt: typos and syntaxes fixes Subject: sched/numa: avoid trapping faults and attempting migration of file-backed dirty pages Subject: mm: check __highest_present_section_nr directly in memory_dev_init() Subject: mm/migrate: properly preserve write attribute in special migrate entry Subject: memcg, thp: do not invoke oom killer on thp charges Subject: z3fold: fix memory leak Subject: mm/z3fold.c: use gfpflags_allow_blocking Subject: mm/ksm.c: fix inconsistent accounting of zero pages Subject: mm: memcg: make sure memory.events is uptodate when waking pollers Subject: swap: divide-by-zero when zero length swap file on ssd Subject: memcg: fix per_node_info cleanup Subject: mm/swapfile.c: make pointer swap_avail_heads static Subject: mm, numa: rework do_pages_move Subject: mm, migrate: remove reason argument from new_page_t Subject: mm: unclutter THP migration Subject: mm/page_alloc: don't reserve ZONE_HIGHMEM for ZONE_MOVABLE request Subject: mm/cma: manage the memory of the CMA area by using the ZONE_MOVABLE Subject: mm/cma: remove ALLOC_CMA Subject: ARM: CMA: avoid double mapping to the CMA area if CONFIG_HIGHMEM=y Subject: mm/thp: don't count ZONE_MOVABLE as the target for freepage reserving Subject: kasan, slub: fix handling of kasan_slab_free hook Subject: kasan: fix invalid-free test crashing the kernel Subject: kasan: prevent compiler from optimizing away memset in tests Subject: procfs: add seq_put_hex_ll to speed up /proc/pid/maps Subject: procfs: optimize seq_pad() to speed up /proc/pid/maps Subject: proc: get rid of task lock/unlock pair to read umask for the "status" file Subject: proc: do less stuff under ->pde_unload_lock Subject: proc: move /proc/sysvipc creation to where it belongs Subject: proc: faster open/close of files without ->release hook Subject: proc: randomize "struct pde_opener" Subject: proc: move "struct pde_opener" to kmem cache Subject: proc: account "struct pde_opener" Subject: proc: add seq_put_decimal_ull_width to speed up /proc/pid/smaps Subject: proc: replace seq_printf on seq_putc to speed up /proc/pid/smaps Subject: proc: optimize single-symbol delimiters to spead up seq_put_decimal_ull Subject: proc: replace seq_printf by seq_put_smth to speed up /proc/pid/status Subject: proc: check permissions earlier for /proc/*/wchan Subject: proc: use set_puts() at /proc/*/wchan Subject: fs/proc/proc_sysctl.c: fix potential page fault while unregistering sysctl table Subject: fs/proc/proc_sysctl.c: remove redundant link check in proc_sys_link_fill_cache() Subject: proc: test /proc/self/wchan Subject: proc: test /proc/self/syscall Subject: proc: move "struct proc_dir_entry" into kmem cache Subject: proc: fix /proc/*/map_files lookup some more Subject: proc: register filesystem last Subject: proc: faster /proc/cmdline Subject: proc: do mmput ASAP for /proc/*/map_files Subject: proc: add selftest for last field of /proc/loadavg Subject: proc: reject "." and ".." as filenames Subject: proc: switch struct proc_dir_entry::count to refcount Subject: proc: selftests: shotgun testing of read/readdir/readlink/write Subject: proc: use slower rb_first() Subject: proc: selftests: test /proc/uptime Subject: taint: convert to indexed initialization Subject: taint: consolidate documentation Subject: taint: add taint for randstruct Subject: uts: create "struct uts_namespace" from kmem_cache Subject: clang-format: add configuration file Subject: task_struct: only use anon struct under randstruct plugin Subject: MAINTAINERS: update email address for Alexandre Bounine Subject: lib/Kconfig.debug: Debug Lockups and Hangs: keep SOFTLOCKUP options together Subject: lib/test_bitmap.c: do not accidentally use stack VLA Subject: lib: add testing module for UBSAN Subject: lib/test_ubsan.c: make test_ubsan_misaligned_access() static Subject: lib/list_debug.c: print unmangled addresses Subject: checkpatch: improve parse_email signature checking Subject: checkpatch.pl: add SPDX license tag check Subject: checkpatch: add Crypto ON_STACK to declaration_macros Subject: checkpatch: add sub routine get_stat_real() Subject: checkpatch: remove unused variable declarations Subject: checkpatch: add sub routine get_stat_here() Subject: checkpatch: warn for use of %px Subject: checkpatch: improve get_quoted_string for TRACE_EVENT macros Subject: checkpatch: two spelling fixes Subject: checkpatch: test SYMBOLIC_PERMS multiple times per line Subject: checkpatch: add test for assignment at start of line Subject: checkpatch: allow space between colon and bracket Subject: checkpatch: whinge about bool bitfields Subject: init/ramdisk: use pr_cont() at the end of ramdisk loading Subject: autofs4: use wait_event_killable Subject: fs/reiserfs/journal.c: add missing resierfs_warning() arg Subject: seq_file: allocate seq_file from kmem_cache Subject: seq_file: account everything to kmemcg Subject: exec: pass stack rlimit into mm layout functions Subject: exec: introduce finalize_exec() before start_thread() Subject: exec: pin stack limit during exec Subject: drivers/rapidio/rio-scan.c: fix typo in comment Subject: rapidio: use a reference count for struct mport_dma_req Subject: kernel/sysctl.c: fix sizeof argument to match variable name Subject: kernel/params.c: downgrade warning for unsafe parameters Subject: ipc/shm: introduce shmctl(SHM_STAT_ANY) Subject: ipc/sem: introduce semctl(SEM_STAT_ANY) Subject: ipc/msg: introduce msgctl(MSG_STAT_ANY) Subject: fs/proc/proc_sysctl.c: fix typo in sysctl_check_table_array() Subject: kernel/sysctl.c: add kdoc comments to do_proc_do{u}intvec_minmax_conv_param Subject: ipc/shm.c: shm_split(): remove unneeded test for NULL shm_file_data.vm_ops Subject: include/linux/kfifo.h: fix comment Subject: fs/dcache.c: add cond_resched() in shrink_dentry_list() Subject: MAINTAINERS: update bouncing aacraid@xxxxxxxxxxx addresses Subject: mm: introduce MAP_FIXED_NOREPLACE Subject: fs, elf: drop MAP_FIXED usage from elf_map Subject: elf: enforce MAP_FIXED on overlaying elf segments Subject: xen, mm: allow deferred page initialization for xen pv domains Subject: linux/const.h: prefix include guard of uapi/linux/const.h with _UAPI Subject: linux/const.h: move UL() macro to include/linux/const.h Subject: linux/const.h: refactor _BITUL and _BITULL a bit Subject: radix tree: use GFP_ZONEMASK bits of gfp_t for flags Subject: mac80211_hwsim: use DEFINE_IDA Subject: arm64: turn flush_dcache_mmap_lock into a no-op Subject: unicore32: turn flush_dcache_mmap_lock into a no-op Subject: export __set_page_dirty Subject: fscache: use appropriate radix tree accessors Subject: xarray: add the xa_lock to the radix_tree_root Subject: page cache: use xa_lock -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html