The patch titled Subject: mm/hmm: rename HMM_PFN_DEVICE_UNADDRESSABLE to HMM_PFN_DEVICE_PRIVATE has been added to the -mm tree. Its filename is mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/process/submit-checklist.rst when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Jérôme Glisse <jglisse@xxxxxxxxxx> Subject: mm/hmm: rename HMM_PFN_DEVICE_UNADDRESSABLE to HMM_PFN_DEVICE_PRIVATE Make naming consistent accross code, DEVICE_PRIVATE is the name use outside HMM code so use that one. Link: http://lkml.kernel.org/r/20180316203552.4155-1-jglisse@xxxxxxxxxx Signed-off-by: Jérôme Glisse <jglisse@xxxxxxxxxx> Cc: Evgeny Baskakov <ebaskakov@xxxxxxxxxx> Cc: Ralph Campbell <rcampbell@xxxxxxxxxx> Cc: Mark Hairgrove <mhairgrove@xxxxxxxxxx> Cc: John Hubbard <jhubbard@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/hmm.h | 4 ++-- mm/hmm.c | 2 +- 2 files changed, 3 insertions(+), 3 deletions(-) diff -puN include/linux/hmm.h~mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private include/linux/hmm.h --- a/include/linux/hmm.h~mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private +++ a/include/linux/hmm.h @@ -88,13 +88,13 @@ struct hmm; * result of vm_insert_pfn() or vm_insert_page(). Therefore, it should not * be mirrored by a device, because the entry will never have HMM_PFN_VALID * set and the pfn value is undefined. - * HMM_PFN_DEVICE_UNADDRESSABLE: unaddressable device memory (ZONE_DEVICE) + * HMM_PFN_DEVICE_PRIVATE: unaddressable device memory (ZONE_DEVICE) */ #define HMM_PFN_VALID (1 << 0) #define HMM_PFN_WRITE (1 << 1) #define HMM_PFN_ERROR (1 << 2) #define HMM_PFN_SPECIAL (1 << 3) -#define HMM_PFN_DEVICE_UNADDRESSABLE (1 << 4) +#define HMM_PFN_DEVICE_PRIVATE (1 << 4) #define HMM_PFN_SHIFT 5 /* diff -puN mm/hmm.c~mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private mm/hmm.c --- a/mm/hmm.c~mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private +++ a/mm/hmm.c @@ -429,7 +429,7 @@ again: pfns[i] |= HMM_PFN_WRITE; } else if (write_fault) goto fault; - pfns[i] |= HMM_PFN_DEVICE_UNADDRESSABLE; + pfns[i] |= HMM_PFN_DEVICE_PRIVATE; } else if (is_migration_entry(entry)) { if (hmm_vma_walk->fault) { pte_unmap(ptep); _ Patches currently in -mm which might be from jglisse@xxxxxxxxxx are mm-hmm-fix-header-file-if-else-endif-maze.patch mm-hmm-hmm_pfns_bad-was-accessing-wrong-struct.patch mm-hmm-use-struct-for-hmm_vma_fault-hmm_vma_get_pfns-parameters.patch mm-hmm-remove-hmm_pfn_read-flag-and-ignore-peculiar-architecture.patch mm-hmm-use-uint64_t-for-hmm-pfn-instead-of-defining-hmm_pfn_t-to-ulong.patch mm-hmm-cleanup-special-vma-handling-vm_special.patch mm-hmm-do-not-differentiate-between-empty-entry-or-missing-directory.patch mm-hmm-rename-hmm_pfn_device_unaddressable-to-hmm_pfn_device_private.patch mm-hmm-move-hmm_pfns_clear-closer-to-where-it-is-use.patch mm-hmm-factor-out-pte-and-pmd-handling-to-simplify-hmm_vma_walk_pmd.patch mm-hmm-change-hmm_vma_fault-to-allow-write-fault-on-page-basis.patch mm-hmm-use-device-driver-encoding-for-hmm-pfn.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html