The patch titled Subject: m68k: rename UL() to TO_UL() has been removed from the -mm tree. Its filename was m68k-rename-ul-to-to_ul.patch This patch was dropped because it is obsolete ------------------------------------------------------ From: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> Subject: m68k: rename UL() to TO_UL() ARM, ARM64 and UniCore32 define UL(x) like follows: #define UL(x) _AC(x, UL) While, M68K defines it differently: #define UL(x) ((unsigned long) (x)) I want to move the former to a common header. Beforehand, this commit renames the latter to avoid name conflict. Link: http://lkml.kernel.org/r/1519301715-31798-3-git-send-email-yamada.masahiro@xxxxxxxxxxxxx Signed-off-by: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> Acked-by: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> Cc: Catalin Marinas <catalin.marinas@xxxxxxx> Cc: David Howells <dhowells@xxxxxxxxxx> Cc: Guan Xuetao <gxt@xxxxxxxxxxxxxxx> Cc: Russell King <rmk+kernel@xxxxxxxxxxxxxxx> Cc: Will Deacon <will.deacon@xxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- arch/m68k/mm/init.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff -puN arch/m68k/mm/init.c~m68k-rename-ul-to-to_ul arch/m68k/mm/init.c --- a/arch/m68k/mm/init.c~m68k-rename-ul-to-to_ul +++ a/arch/m68k/mm/init.c @@ -122,9 +122,9 @@ void free_initmem(void) void __init print_memmap(void) { -#define UL(x) ((unsigned long) (x)) -#define MLK(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 10 -#define MLM(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 20 +#define TO_UL(x) ((unsigned long) (x)) +#define MLK(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 10 +#define MLM(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 20 #define MLK_ROUNDUP(b, t) b, t, DIV_ROUND_UP(((t) - (b)), 1024) pr_notice("Virtual kernel memory layout:\n" _ Patches currently in -mm which might be from yamada.masahiro@xxxxxxxxxxxxx are linux-consth-prefix-include-guard-of-uapi-linux-consth-with-_uapi.patch linux-consth-move-ul-macro-to-include-linux-consth.patch linux-consth-refactor-_bitul-and-_bitull-a-bit.patch linux-consth-move-bit_ull-to-linux-consth-for-use-in-assembly.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html