The patch titled Subject: rename bitmap_copy_safe to bitmap_copy_clear_tail has been removed from the -mm tree. Its filename was bitmap-new-bitmap_copy_safe-and-bitmap_fromto_arr32-fix.patch This patch was dropped because it was folded into bitmap-new-bitmap_copy_safe-and-bitmap_fromto_arr32.patch ------------------------------------------------------ From: Yury Norov <ynorov@xxxxxxxxxxxxxxxxxx> Subject: rename bitmap_copy_safe to bitmap_copy_clear_tail Rename is proposed in review: https://lkml.org/lkml/2018/1/8/1052 Link: http://lkml.kernel.org/r/20180201172508.5739-3-ynorov@xxxxxxxxxxxxxxxxxx Signed-off-by: Yury Norov <ynorov@xxxxxxxxxxxxxxxxxx> Suggested-by: Rasmus Villemoes <linux@xxxxxxxxxxxxxxxxxx> Cc: Ben Hutchings <ben@xxxxxxxxxxxxxxx> Cc: David Decotigny <decot@xxxxxxxxxxxx>, Cc: David S. Miller <davem@xxxxxxxxxxxxx>, Cc: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> Cc: Matthew Wilcox <mawilcox@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/linux/bitmap.h | 10 +++++----- 1 file changed, 5 insertions(+), 5 deletions(-) diff -puN include/linux/bitmap.h~bitmap-new-bitmap_copy_safe-and-bitmap_fromto_arr32-fix include/linux/bitmap.h --- a/include/linux/bitmap.h~bitmap-new-bitmap_copy_safe-and-bitmap_fromto_arr32-fix +++ a/include/linux/bitmap.h @@ -233,7 +233,7 @@ static inline void bitmap_copy(unsigned /* * Copy bitmap and clear tail bits in last word. */ -static inline void bitmap_copy_safe(unsigned long *dst, +static inline void bitmap_copy_clear_tail(unsigned long *dst, const unsigned long *src, unsigned int nbits) { bitmap_copy(dst, src, nbits); @@ -251,11 +251,11 @@ extern void bitmap_from_arr32(unsigned l extern void bitmap_to_arr32(u32 *buf, const unsigned long *bitmap, unsigned int nbits); #else -#define bitmap_from_arr32(bitmap, buf, nbits) \ - bitmap_copy_safe((unsigned long *) (bitmap), \ +#define bitmap_from_arr32(bitmap, buf, nbits) \ + bitmap_copy_clear_tail((unsigned long *) (bitmap), \ (const unsigned long *) (buf), (nbits)) -#define bitmap_to_arr32(buf, bitmap, nbits) \ - bitmap_copy_safe((unsigned long *) (buf), \ +#define bitmap_to_arr32(buf, bitmap, nbits) \ + bitmap_copy_clear_tail((unsigned long *) (buf), \ (const unsigned long *) (bitmap), (nbits)) #endif _ Patches currently in -mm which might be from ynorov@xxxxxxxxxxxxxxxxxx are bitmap-new-bitmap_copy_safe-and-bitmap_fromto_arr32.patch bitmap-replace-bitmap_fromto_u32array.patch bitmap-replace-bitmap_fromto_u32array-fix-2.patch lib-test_find_bitc-rename-to-find_bit_benchmarkc.patch lib-find_bit_benchmarkc-improvements.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html