The patch titled Subject: truncate: use i_blocksize() has been removed from the -mm tree. Its filename was fs-add-i_blocksize-fix.patch This patch was dropped because it was folded into fs-add-i_blocksize.patch ------------------------------------------------------ From: Geliang Tang <geliangtang@xxxxxxxxx> Subject: truncate: use i_blocksize() Since i_blocksize() helper has been defined in fs.h, use it instead of open-coding. Link: http://lkml.kernel.org/r/9c8b2cd83c8f5653805d43debde9fa8817e02fc4.1484895804.git.geliangtang@xxxxxxxxx Signed-off-by: Geliang Tang <geliangtang@xxxxxxxxx> Reviewed-by: Ross Zwisler <ross.zwisler@xxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/truncate.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff -puN mm/truncate.c~fs-add-i_blocksize-fix mm/truncate.c --- a/mm/truncate.c~fs-add-i_blocksize-fix +++ a/mm/truncate.c @@ -786,7 +786,7 @@ EXPORT_SYMBOL(truncate_setsize); */ void pagecache_isize_extended(struct inode *inode, loff_t from, loff_t to) { - int bsize = 1 << inode->i_blkbits; + int bsize = i_blocksize(inode); loff_t rounded_from; struct page *page; pgoff_t index; _ Patches currently in -mm which might be from geliangtang@xxxxxxxxx are fs-add-i_blocksize.patch nilfs2-use-nilfs_btree_node_size.patch nilfs2-use-i_blocksize.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html