From: Adygzhy Ondar <ondar07@xxxxxxxxx> Subject: mm/bootmem.c: cosmetic improvement of code readability The obvious number of bits in a byte is replaced by BITS_PER_BYTE macro in bootmap_bytes() Link: http://lkml.kernel.org/r/1483781600-5136-1-git-send-email-ondar07@xxxxxxxxx Signed-off-by: Adygzhy Ondar <ondar07@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/bootmem.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff -puN mm/bootmem.c~mm-bootmemc-cosmetic-improvement-of-code-readability mm/bootmem.c --- a/mm/bootmem.c~mm-bootmemc-cosmetic-improvement-of-code-readability +++ a/mm/bootmem.c @@ -53,7 +53,7 @@ early_param("bootmem_debug", bootmem_deb static unsigned long __init bootmap_bytes(unsigned long pages) { - unsigned long bytes = DIV_ROUND_UP(pages, 8); + unsigned long bytes = DIV_ROUND_UP(pages, BITS_PER_BYTE); return ALIGN(bytes, sizeof(long)); } _ -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html