The patch titled Subject: m68k: rename UL() to TO_UL() has been removed from the -mm tree. Its filename was m68k-rename-ul-to-to_ul.patch This patch was dropped because it was withdrawn ------------------------------------------------------ From: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> Subject: m68k: rename UL() to TO_UL() Patch series "linux/const.h: cleanups of macros such as UL(), _BITUL(), BIT() etc", v2. ARM, ARM64, UniCore32 define UL() as a shorthand of _AC(..., UL). In the future, more architectures may introduce it, so move the definition to include/linux/const.h. The _AC() is used for either (likely) UL or (unlikely) ULL. Having UL(L) in a common place can avoid direct use of _AC(). The _AC() is defined under the uapi directory, so it compels underscore-prefixed macros even for unexported headers. I see similar situation for _BITUL(). This is available in both C and assembly. However, it is defined in an uapi header, so direct use of the underscore macro is needed even for unexported headers. The 3/3 makes BIT() available in assembly too, which will be more suitable for use in unexported headers. This patch (of 4): ARM, ARM64 and UniCore32 define UL(x) like follows: #define UL(x) _AC(x, UL) While, M68K defines it differently: #define UL(x) ((unsigned long) (x)) I am moving the former to a common header in the next commit. Beforehand, this commit renames the latter to avoid name conflict. Link: http://lkml.kernel.org/r/1483582810-7046-2-git-send-email-yamada.masahiro@xxxxxxxxxxxxx Signed-off-by: Masahiro Yamada <yamada.masahiro@xxxxxxxxxxxxx> Acked-by: Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- arch/m68k/mm/init.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff -puN arch/m68k/mm/init.c~m68k-rename-ul-to-to_ul arch/m68k/mm/init.c --- a/arch/m68k/mm/init.c~m68k-rename-ul-to-to_ul +++ a/arch/m68k/mm/init.c @@ -121,9 +121,9 @@ void free_initmem(void) void __init print_memmap(void) { -#define UL(x) ((unsigned long) (x)) -#define MLK(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 10 -#define MLM(b, t) UL(b), UL(t), (UL(t) - UL(b)) >> 20 +#define TO_UL(x) ((unsigned long) (x)) +#define MLK(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 10 +#define MLM(b, t) TO_UL(b), TO_UL(t), (TO_UL(t) - TO_UL(b)) >> 20 #define MLK_ROUNDUP(b, t) b, t, DIV_ROUND_UP(((t) - (b)), 1024) pr_notice("Virtual kernel memory layout:\n" _ Patches currently in -mm which might be from yamada.masahiro@xxxxxxxxxxxxx are linux-consth-move-ul-macro-to-include-linux-consth.patch linux-consth-refactor-_bitul-and-_bitull-a-bit.patch linux-consth-move-bit_ull-to-linux-consth-for-use-in-assembly.patch scripts-spellingtxt-add-swith-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-swithc-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-an-user-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-an-union-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-an-one-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-partiton-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-aligment-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-algined-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-efective-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-varible-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-embeded-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-againt-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-neded-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-unneded-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-intialization-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-initialiazation-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-intialised-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-comsumer-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-disbled-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-overide-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-overrided-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-configuartion-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-applys-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-explictely-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-omited-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-disassocation-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-deintialized-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-overwritting-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-overwriten-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-therfore-pattern-and-fix-typo-instances.patch scripts-spellingtxt-add-followings-pattern-and-fix-typo-instances.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html