The patch titled Subject: rapidio: use kobj_to_dev() has been removed from the -mm tree. Its filename was rapidio-use-kobj_to_dev.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Geliang Tang <geliangtang@xxxxxxx> Subject: rapidio: use kobj_to_dev() Use kobj_to_dev() instead of open-coding it. Signed-off-by: Geliang Tang <geliangtang@xxxxxxx> Acked-by: "Bounine, Alexandre" <Alexandre.Bounine@xxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- drivers/rapidio/rio-sysfs.c | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) diff -puN drivers/rapidio/rio-sysfs.c~rapidio-use-kobj_to_dev drivers/rapidio/rio-sysfs.c --- a/drivers/rapidio/rio-sysfs.c~rapidio-use-kobj_to_dev +++ a/drivers/rapidio/rio-sysfs.c @@ -125,8 +125,7 @@ rio_read_config(struct file *filp, struc struct bin_attribute *bin_attr, char *buf, loff_t off, size_t count) { - struct rio_dev *dev = - to_rio_dev(container_of(kobj, struct device, kobj)); + struct rio_dev *dev = to_rio_dev(kobj_to_dev(kobj)); unsigned int size = 0x100; loff_t init_off = off; u8 *data = (u8 *) buf; @@ -197,8 +196,7 @@ rio_write_config(struct file *filp, stru struct bin_attribute *bin_attr, char *buf, loff_t off, size_t count) { - struct rio_dev *dev = - to_rio_dev(container_of(kobj, struct device, kobj)); + struct rio_dev *dev = to_rio_dev(kobj_to_dev(kobj)); unsigned int size = count; loff_t init_off = off; u8 *data = (u8 *) buf; _ Patches currently in -mm which might be from geliangtang@xxxxxxx are -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html