The patch titled reparent_to_init(): use has_rt_policy() has been removed from the -mm tree. Its filename is reparent_to_init-use-has_rt_policy.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ Subject: reparent_to_init(): use has_rt_policy() From: Oleg Nesterov <oleg@xxxxxxxxxx> Remove open-coded has_rt_policy(), no changes in kernel/exit.o Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx> Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> Cc: Ingo Molnar <mingo@xxxxxxx> Cc: Steven Rostedt <rostedt@xxxxxxxxxxx> Cc: Nick Piggin <nickpiggin@xxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- kernel/exit.c | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff -puN kernel/exit.c~reparent_to_init-use-has_rt_policy kernel/exit.c --- a/kernel/exit.c~reparent_to_init-use-has_rt_policy +++ a/kernel/exit.c @@ -281,9 +281,7 @@ static void reparent_to_init(void) /* Set the exit signal to SIGCHLD so we signal init on exit */ current->exit_signal = SIGCHLD; - if ((current->policy == SCHED_NORMAL || - current->policy == SCHED_BATCH) - && (task_nice(current) < 0)) + if (!has_rt_policy(current) && (task_nice(current) < 0)) set_user_nice(current, 0); /* cpus_allowed? */ /* rt_priority? */ _ Patches currently in -mm which might be from oleg@xxxxxxxxxx are origin.patch git-block.patch proc-readdir-race-fix-take-3-race-fix.patch vt-rework-the-console-spawning-variables.patch vt-make-vt_pid-a-struct-pid-making-it-pid-wrap-around-safe.patch simplify-pid-iterators.patch file-add-locking-to-f_getown.patch proc-convert-task_sig-to-use-lock_task_sighand.patch proc-convert-do_task_stat-to-use-lock_task_sighand.patch proc-drop-tasklist-lock-in-task_state.patch proc-properly-compute-tgid_offset.patch proc-remove-trailing-blank-entry-from-pid_entry-arrays.patch proc-remove-the-useless-smp-safe-comments-from-proc.patch proc-comment-what-proc_fill_cache-does.patch introduce-get_task_pid-to-fix-unsafe-get_pid.patch rcu-simplify-improve-batch-tuning.patch pidhash-temporary-debug-checks.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html