The patch titled Subject: mm/kasan: rename kasan_enabled() to kasan_report_enabled() has been removed from the -mm tree. Its filename was mm-kasan-rename-kasan_enabled-to-kasan_report_enabled.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: "Aneesh Kumar K.V" <aneesh.kumar@xxxxxxxxxxxxxxxxxx> Subject: mm/kasan: rename kasan_enabled() to kasan_report_enabled() The function only disable/enable reporting. In the later patch we will be adding a kasan early enable/disable. Rename kasan_enabled to properly reflect its function. Signed-off-by: Aneesh Kumar K.V <aneesh.kumar@xxxxxxxxxxxxxxxxxx> Reviewed-by: Andrey Ryabinin <ryabinin.a.a@xxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/kasan/kasan.h | 2 +- mm/kasan/report.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff -puN mm/kasan/kasan.h~mm-kasan-rename-kasan_enabled-to-kasan_report_enabled mm/kasan/kasan.h --- a/mm/kasan/kasan.h~mm-kasan-rename-kasan_enabled-to-kasan_report_enabled +++ a/mm/kasan/kasan.h @@ -63,7 +63,7 @@ static inline const void *kasan_shadow_t << KASAN_SHADOW_SCALE_SHIFT); } -static inline bool kasan_enabled(void) +static inline bool kasan_report_enabled(void) { return !current->kasan_depth; } diff -puN mm/kasan/report.c~mm-kasan-rename-kasan_enabled-to-kasan_report_enabled mm/kasan/report.c --- a/mm/kasan/report.c~mm-kasan-rename-kasan_enabled-to-kasan_report_enabled +++ a/mm/kasan/report.c @@ -220,7 +220,7 @@ void kasan_report(unsigned long addr, si { struct kasan_access_info info; - if (likely(!kasan_enabled())) + if (likely(!kasan_report_enabled())) return; info.access_addr = (void *)addr; _ Patches currently in -mm which might be from aneesh.kumar@xxxxxxxxxxxxxxxxxx are -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html