The patch titled Subject: drm: use kvfree() in drm_free_large() has been removed from the -mm tree. Its filename was drm-use-kvfree-in-drm_free_large.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Pekka Enberg <penberg@xxxxxxxxxx> Subject: drm: use kvfree() in drm_free_large() Use kvfree() instead of open-coding it. Signed-off-by: Pekka Enberg <penberg@xxxxxxxxxx> Cc: David Airlie <airlied@xxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- include/drm/drm_mem_util.h | 5 +---- 1 file changed, 1 insertion(+), 4 deletions(-) diff -puN include/drm/drm_mem_util.h~drm-use-kvfree-in-drm_free_large include/drm/drm_mem_util.h --- a/include/drm/drm_mem_util.h~drm-use-kvfree-in-drm_free_large +++ a/include/drm/drm_mem_util.h @@ -56,10 +56,7 @@ static __inline__ void *drm_malloc_ab(si static __inline void drm_free_large(void *ptr) { - if (!is_vmalloc_addr(ptr)) - return kfree(ptr); - - vfree(ptr); + kvfree(ptr); } #endif _ Patches currently in -mm which might be from penberg@xxxxxxxxxx are slab-infrastructure-for-bulk-object-allocation-and-freeing-v3.patch slab-infrastructure-for-bulk-object-allocation-and-freeing-v3-fix.patch slub-bulk-alloc-extract-objects-from-the-per-cpu-slab.patch page-flags-define-behavior-slb-related-flags-on-compound-pages.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html