The patch titled Subject: lib/sort: Move the alignment check into a function has been added to the -mm tree. Its filename is lib-sort-add-64-bit-swap-function-v2-fix.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/lib-sort-add-64-bit-swap-function-v2-fix.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/lib-sort-add-64-bit-swap-function-v2-fix.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/SubmitChecklist when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Daniel Wagner <daniel.wagner@xxxxxxxxxxxx> Subject: lib/sort: Move the alignment check into a function Rasmus Villemoes suggestes to move the aliment check into a separate function in order to improve the readability. Furthermore, let's avoid the switch statement since gcc might mess it up. My gcc 4.9.2 produces the same code for the x86_64 configuration. That is switch (size) { case 4: if (alignment_ok(base, 4)) swap_func = u32_swap; break; case 8: if (alignment_ok(base, 8)) swap_func = u64_swap; break; } if (!swap_func) swap_func = generic_swap; } resulted into the same object code. Link: https://lkml.org/lkml/2015/5/15/89 Signed-off-by: Daniel Wagner <daniel.wagner@xxxxxxxxxxxx> Suggested-by: Rasmus Villemoes <linux@xxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- lib/sort.c | 30 +++++++++--------------------- 1 file changed, 9 insertions(+), 21 deletions(-) diff -puN lib/sort.c~lib-sort-add-64-bit-swap-function-v2-fix lib/sort.c --- a/lib/sort.c~lib-sort-add-64-bit-swap-function-v2-fix +++ a/lib/sort.c @@ -8,6 +8,12 @@ #include <linux/export.h> #include <linux/sort.h> +static int alignment_ok(const void *base, int align) +{ + return IS_ENABLED(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) || + ((unsigned long)base & (align - 1)) == 0; +} + static void u32_swap(void *a, void *b, int size) { u32 t = *(u32 *)a; @@ -58,29 +64,11 @@ void sort(void *base, size_t num, size_t int i = (num/2 - 1) * size, n = num * size, c, r; if (!swap_func) { -#if defined(CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS) - switch (size) { - case 4: + if (size == 4 && alignment_ok(base, 4)) swap_func = u32_swap; - break; - case 8: + else if (size == 8 && alignment_ok(base, 8)) swap_func = u64_swap; - break; - } -#else - switch (size) { - case 4: - if (((unsigned long)base & 3) == 0) - swap_func = u32_swap; - break; - case 8: - if (((unsigned long)base & 7) == 0) - swap_func = u64_swap; - break; - } -#endif /* CONFIG_HAVE_EFFICIENT_UNALIGNED_ACCESS */ - - if (!swap_func) + else swap_func = generic_swap; } _ Patches currently in -mm which might be from daniel.wagner@xxxxxxxxxxxx are lib-sort-add-64-bit-swap-function.patch lib-sort-add-64-bit-swap-function-v2.patch lib-sort-add-64-bit-swap-function-v2-fix.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html