The patch titled Subject: mm/memblock.c: rename local variable of memblock_type to `type' has been added to the -mm tree. Its filename is mm-memblockc-name-the-local-variable-of-memblock_type-as-type.patch This patch should soon appear at http://ozlabs.org/~akpm/mmots/broken-out/mm-memblockc-name-the-local-variable-of-memblock_type-as-type.patch and later at http://ozlabs.org/~akpm/mmotm/broken-out/mm-memblockc-name-the-local-variable-of-memblock_type-as-type.patch Before you just go and hit "reply", please: a) Consider who else should be cc'ed b) Prefer to cc a suitable mailing list as well c) Ideally: find the original patch on the mailing list and do a reply-to-all to that, adding suitable additional cc's *** Remember to use Documentation/SubmitChecklist when testing your code *** The -mm tree is included into linux-next and is updated there every 3-4 working days ------------------------------------------------------ From: Baoquan He <bhe@xxxxxxxxxx> Subject: mm/memblock.c: rename local variable of memblock_type to `type' A small cleanup. Seems in e3239ff9 ("memblock: Rename memblock_region to memblock_type and memblock_property to memblock_region") this one was missed. Signed-off-by: Baoquan He <bhe@xxxxxxxxxx> Cc: Benjamin Herrenschmidt <benh@xxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- mm/memblock.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff -puN mm/memblock.c~mm-memblockc-name-the-local-variable-of-memblock_type-as-type mm/memblock.c --- a/mm/memblock.c~mm-memblockc-name-the-local-variable-of-memblock_type-as-type +++ a/mm/memblock.c @@ -699,14 +699,14 @@ static int __init_memblock memblock_rese int nid, unsigned long flags) { - struct memblock_type *_rgn = &memblock.reserved; + struct memblock_type *type = &memblock.reserved; memblock_dbg("memblock_reserve: [%#016llx-%#016llx] flags %#02lx %pF\n", (unsigned long long)base, (unsigned long long)base + size - 1, flags, (void *)_RET_IP_); - return memblock_add_range(_rgn, base, size, nid, flags); + return memblock_add_range(type, base, size, nid, flags); } int __init_memblock memblock_reserve(phys_addr_t base, phys_addr_t size) _ Patches currently in -mm which might be from bhe@xxxxxxxxxx are origin.patch mm-memblockc-name-the-local-variable-of-memblock_type-as-type.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html