The patch titled Subject: lib/dynamic_debug.c: use seq_open_private() instead of seq_open() has been removed from the -mm tree. Its filename was lib-use-seq_open_private-instead-of-seq_open.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ From: Rob Jones <rob.jones@xxxxxxxxxxxxxxx> Subject: lib/dynamic_debug.c: use seq_open_private() instead of seq_open() Using seq_open_private() removes boilerplate code from ddebug_proc_open(). The resultant code is shorter and easier to follow. This patch does not change any functionality. Signed-off-by: Rob Jones <rob.jones@xxxxxxxxxxxxxxx> Acked-by: Jason Baron <jbaron@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> --- lib/dynamic_debug.c | 17 ++--------------- 1 file changed, 2 insertions(+), 15 deletions(-) diff -puN lib/dynamic_debug.c~lib-use-seq_open_private-instead-of-seq_open lib/dynamic_debug.c --- a/lib/dynamic_debug.c~lib-use-seq_open_private-instead-of-seq_open +++ a/lib/dynamic_debug.c @@ -819,22 +819,9 @@ static const struct seq_operations ddebu */ static int ddebug_proc_open(struct inode *inode, struct file *file) { - struct ddebug_iter *iter; - int err; - vpr_info("called\n"); - - iter = kzalloc(sizeof(*iter), GFP_KERNEL); - if (iter == NULL) - return -ENOMEM; - - err = seq_open(file, &ddebug_proc_seqops); - if (err) { - kfree(iter); - return err; - } - ((struct seq_file *)file->private_data)->private = iter; - return 0; + return seq_open_private(file, &ddebug_proc_seqops, + sizeof(struct ddebug_iter)); } static const struct file_operations ddebug_proc_fops = { _ Patches currently in -mm which might be from rob.jones@xxxxxxxxxxxxxxx are origin.patch -- To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html