The patch titled fixes kerneldoc errors in usbcore-auto(susp/res)-patch has been added to the -mm tree. Its filename is gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure-2.patch See http://www.zip.com.au/~akpm/linux/patches/stuff/added-to-mm.txt to find out what to do about this ------------------------------------------------------ Subject: fixes kerneldoc errors in usbcore-auto(susp/res)-patch From: Henrik Kretzschmar <henne@xxxxxxxxxxxxxxxx> Fixes kerneldoc errors on usb/core/driver.c, which occured in 2.6.18-rc6-mm2 gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure.patch Signed-off-by: Henrik Kretzschmar <henne@xxxxxxxxxxxxxxxx> Cc: Greg KH <greg@xxxxxxxxx> Acked-by: Alan Stern <stern@xxxxxxxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- drivers/usb/core/driver.c | 12 ++++++------ 1 files changed, 6 insertions(+), 6 deletions(-) diff -puN drivers/usb/core/driver.c~gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure-2 drivers/usb/core/driver.c --- a/drivers/usb/core/driver.c~gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure-2 +++ a/drivers/usb/core/driver.c @@ -1102,8 +1102,8 @@ int usb_resume_both(struct usb_device *u /** * usb_autosuspend_device - delayed autosuspend of a USB device and its interfaces - * @udev - the usb_device to autosuspend - * @dec_usage_cnt - flag to decrement @udev's PM-usage counter + * @udev: the usb_device to autosuspend + * @dec_usage_cnt: flag to decrement @udev's PM-usage counter * * This routine should be called when a core subsystem is finished using * @udev and wants to allow it to autosuspend. Examples would be when @@ -1139,8 +1139,8 @@ void usb_autosuspend_device(struct usb_d /** * usb_autoresume_device - immediately autoresume a USB device and its interfaces - * @udev - the usb_device to autoresume - * @inc_usage_cnt - flag to increment @udev's PM-usage counter + * @udev: the usb_device to autoresume + * @inc_usage_cnt: flag to increment @udev's PM-usage counter * * This routine should be called when a core subsystem wants to use @udev * and needs to guarantee that it is not suspended. In addition, the @@ -1180,7 +1180,7 @@ int usb_autoresume_device(struct usb_dev /** * usb_autopm_put_interface - decrement a USB interface's PM-usage counter - * @intf - the usb_interface whose counter should be decremented + * @intf: the usb_interface whose counter should be decremented * * This routine should be called by an interface driver when it is * finished using @intf and wants to allow it to autosuspend. A typical @@ -1227,7 +1227,7 @@ EXPORT_SYMBOL_GPL(usb_autopm_put_interfa /** * usb_autopm_get_interface - increment a USB interface's PM-usage counter - * @intf - the usb_interface whose counter should be incremented + * @intf: the usb_interface whose counter should be incremented * * This routine should be called by an interface driver when it wants to * use @intf and needs to guarantee that it is not suspended. In addition, _ Patches currently in -mm which might be from henne@xxxxxxxxxxxxxxxx are git-libata-all.patch kerneldoc-error-on-ata_piixc.patch git-netdev-all.patch git-net.patch git-scsi-misc.patch pci_module_init-conversion-in-scsi-subsys-2nd-try.patch gregkh-usb-usbcore-add-autosuspend-autoresume-infrastructure-2.patch docbook-fix-segfault-in-docprocc.patch pci_module_init-convertion-in-ata_genericc.patch pci_module_init-convertion-in-ata_genericc-fix.patch pci_module_init-convertion-in-amso1100-driver.patch pci_module_init-convertion-for-k8_edacc.patch pci_module_init-convertion-in-the-legacy-megaraid-driver.patch nozomi-pci_module_init-conversion.patch pci_module_init-convertion-in-olympicc.patch pci_module_init-conversion-for-pata_pdc2027x.patch pci_module_init-convertion-in-tmscsimc.patch mark-pci_module_init-deprecated.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html