The patch titled uml: use ptrace-abi.h instead of ptrace.h has been removed from the -mm tree. Its filename is uml-use-ptrace-abih-instead-of-ptraceh.patch This patch was dropped because Andi changes broke it ------------------------------------------------------ Subject: uml: use ptrace-abi.h instead of ptrace.h From: Jeff Dike <jdike@xxxxxxxxxxx> Include the host architecture's ptrace-abi.h instead of ptrace.h. There was some cpp mangling of names around the ptrace.h include to avoid symbol clashes between UML and the host architecture. Most of these can go away. The exception is struct pt_regs, which is convenient to have in userspace, but must be renamed in order that UML can define its own. Signed-off-by: Jeff Dike <jdike@xxxxxxxxxxx> Cc: Chuck Ebbert <76306.1226@xxxxxxxxxxxxxx> Cc: Zachary Amsden <zach@xxxxxxxxxx> Cc: Rusty Russell <rusty@xxxxxxxxxxxxxxx> Cc: Andi Kleen <ak@xxxxxx> Cc: Jeremy Fitzhardinge <jeremy@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- include/asm-um/ptrace-generic.h | 11 +---------- 1 file changed, 1 insertion(+), 10 deletions(-) diff -puN include/asm-um/ptrace-generic.h~uml-use-ptrace-abih-instead-of-ptraceh include/asm-um/ptrace-generic.h --- a/include/asm-um/ptrace-generic.h~uml-use-ptrace-abih-instead-of-ptraceh +++ a/include/asm-um/ptrace-generic.h @@ -8,18 +8,9 @@ #ifndef __ASSEMBLY__ - #define pt_regs pt_regs_subarch -#define show_regs show_regs_subarch -#define send_sigtrap send_sigtrap_subarch - -#include "asm/arch/ptrace.h" - +#include "asm/arch/ptrace-abi.h" #undef pt_regs -#undef show_regs -#undef send_sigtrap -#undef user_mode -#undef instruction_pointer #include "sysdep/ptrace.h" _ Patches currently in -mm which might be from jdike@xxxxxxxxxxx are reduce-max_nr_zones-make-zone_highmem-optional-fix-fix-fix.patch uml-use-ptrace-abih-instead-of-ptraceh.patch uml-use-klibc-setjmp-longjmp.patch uml-use-array_size-more-assiduously.patch uml-fix-stack-alignment.patch uml-whitespace-fixes.patch uml-fix-handling-of-failed-execs-of-helpers.patch uml-improve-sigbus-diagnostics.patch uml-sigio-cleanups.patch uml-move-signal-handlers-to-arch-code.patch uml-move-signal-handlers-to-arch-code-fix.patch uml-timer-cleanups.patch uml-remove-unused-variable.patch uml-clean-our-set_ether_mac.patch uml-stack-usage-reduction.patch uml-use-mcmodel=kernel-for-x86_64.patch uml-fix-proc-vs-interrupt-context-spinlock-deadlock.patch uml-remove-pte_mkexec.patch simplify-update_times-avoid-jiffies-jiffies_64-aliasing-problem-2.patch kill-wall_jiffies.patch const-struct-tty_operations.patch namespaces-utsname-switch-to-using-uts-namespaces.patch introduce-kernel_execve.patch rename-the-provided-execve-functions-to-kernel_execve.patch provide-kernel_execve-on-all-architectures.patch provide-kernel_execve-on-all-architectures-fix.patch remove-the-use-of-_syscallx-macros-in-uml.patch sh64-remove-the-use-of-kernel-syscalls.patch remove-remaining-errno-and-__kernel_syscalls__-references.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html