The patch titled make drivers/hwmon/hdaps.c:transform_axes() static has been added to the -mm tree. Its filename is hdaps-unify-and-cache-hdaps-readouts-fix.patch See http://www.zip.com.au/~akpm/linux/patches/stuff/added-to-mm.txt to find out what to do about this ------------------------------------------------------ Subject: make drivers/hwmon/hdaps.c:transform_axes() static From: Adrian Bunk <bunk@xxxxxxxxx> On Sun, Aug 13, 2006 at 01:24:54AM -0700, Andrew Morton wrote: >... > Changes since 2.6.18-rc3-mm2: >... > +hdaps-unify-and-cache-hdaps-readouts.patch >... > HDAPS driver updates transform_axes() isn't a good name for a global function. Thankfully, it can simply made static. Signed-off-by: Adrian Bunk <bunk@xxxxxxxxx> Acked-by: Shem Multinymous <multinymous@xxxxxxxxx> Cc: Pavel Machek <pavel@xxxxxxx> Cc: Robert Love <rml@xxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- drivers/hwmon/hdaps.c | 2 +- 1 files changed, 1 insertion(+), 1 deletion(-) diff -puN drivers/hwmon/hdaps.c~hdaps-unify-and-cache-hdaps-readouts-fix drivers/hwmon/hdaps.c --- a/drivers/hwmon/hdaps.c~hdaps-unify-and-cache-hdaps-readouts-fix +++ a/drivers/hwmon/hdaps.c @@ -72,7 +72,7 @@ static u8 km_activity; static int rest_x, rest_y; /* calibrated rest position */ /* Some models require an axis transformation to the standard reprsentation */ -void transform_axes(int *x, int *y) +static void transform_axes(int *x, int *y) { if (hdaps_invert) { *x = -*x; _ Patches currently in -mm which might be from bunk@xxxxxxxxx are add-force-of-use-mmconfig.patch make-drivers-cpufreq-cpufreq_ondemandcpowersave_bias_target-static.patch git-dvb.patch git-gfs2.patch git-input.patch git-libata-all.patch git-mtd.patch drivers-net-e1000-possible-cleanups.patch git-net.patch security-selinux-hooksc-make-4-functions-static.patch fs-nfs-make-code-static.patch git-ocfs2.patch git-pcmcia.patch include-scsi-libsash-should-include-linux-scatterlisth.patch gregkh-pci-acpiphp-configure-_prt-v3-cleanup.patch git-scsi-misc.patch drivers-scsi-aic7xxx-possible-cleanups.patch drivers-scsi-small-cleanups.patch drivers-scsi-qla2xxx-make-some-functions-static.patch drivers-scsi-aic7xxx-aic79xx_corec-make-ahd_match_scb-static.patch drivers-scsi-aic7xxx-possible-cleanups-2.patch drivers-scsi-advansysc-cleanups.patch make-drivers-scsi-aic7xxx-aic79xx_coreahd_set_tags-static.patch megaraid-fix-warnings-when-config_proc_fs=n.patch git-cryptodev.patch mm-make-functions-static.patch acx1xx-wireless-driver.patch drivers-edac-make-code-static.patch inode-diet-eliminate-i_blksize-and-use-a-per-superblock-default-fix.patch reiserfs-warn-about-the-useless-nolargeio-option.patch x86-microcode-add-sysfs-and-hotplug-support-fix-fix-2.patch drivers-char-scx200_gpioc-make-code-static.patch drivers-char-pc8736x_gpioc-remove-unused-static-functions.patch hdaps-unify-and-cache-hdaps-readouts-fix.patch generic-ioremap_page_range-i386-conversion-fix.patch fs-ecryptfs-possible-cleanups.patch ecryptfs-add-a-maintainers-entry.patch make-kernel-sysctlc_proc_do_string-static.patch namespaces-utsname-sysctl-hack-fix.patch namespaces-utsname-implement-clone_newuts-flag.patch fs-reiser4-possible-cleanups.patch drivers-ide-cleanups.patch md-the-scheduled-removal-of-the-start_array-ioctl-for-md.patch srcu-3-add-srcu-operations-to-rcutorture-fix.patch the-scheduled-removal-of-some-oss-drivers.patch the-scheduled-removal-of-some-oss-drivers-fix.patch the-scheduled-removal-of-some-oss-drivers-fix-fix.patch kill-sound-oss-_symsc.patch schedule-obsolete-oss-drivers-for-removal-2nd-round.patch slab-cache-shrinker-statistics.patch debug-shared-irqs-kconfig-fix.patch i386-enable-4k-stacks-by-default.patch mutex-subsystem-synchro-test-module.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html