The patch titled cleanup next_tid() has been removed from the -mm tree. Its filename is cleanup-next_tid.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ Subject: cleanup next_tid() From: Oleg Nesterov <oleg@xxxxxxxxxx> Try to make next_tid() a bit more readable and deletes unnecessary "pid_alive(pos)" check. Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx> Cc: "Eric W. Biederman" <ebiederm@xxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- fs/proc/base.c | 14 +++++++------- 1 file changed, 7 insertions(+), 7 deletions(-) diff -puN fs/proc/base.c~cleanup-next_tid fs/proc/base.c --- a/fs/proc/base.c~cleanup-next_tid +++ a/fs/proc/base.c @@ -2267,15 +2267,15 @@ out: */ static struct task_struct *next_tid(struct task_struct *start) { - struct task_struct *pos; + struct task_struct *pos = NULL; rcu_read_lock(); - pos = start; - if (pid_alive(start)) + if (pid_alive(start)) { pos = next_thread(start); - if (pid_alive(pos) && (pos != start->group_leader)) - get_task_struct(pos); - else - pos = NULL; + if (thread_group_leader(pos)) + pos = NULL; + else + get_task_struct(pos); + } rcu_read_unlock(); put_task_struct(start); return pos; _ Patches currently in -mm which might be from oleg@xxxxxxxxxx are origin.patch sched-uninline-task_rq_lock.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html