The patch titled wait_table and zonelist initializing for memory hotadd: change name of wait_table_size() has been removed from the -mm tree. Its filename is wait_table-and-zonelist-initializing-for-memory-hotadd-change-name-of-wait_table_size.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ Subject: wait_table and zonelist initializing for memory hotadd: change name of wait_table_size() From: Yasunori Goto <y-goto@xxxxxxxxxxxxxx> This is just to rename from wait_table_size() to wait_table_hash_nr_entries(). Signed-off-by: Yasunori Goto <y-goto@xxxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- include/linux/mmzone.h | 4 ++-- mm/page_alloc.c | 12 +++++++----- 2 files changed, 9 insertions(+), 7 deletions(-) diff -puN include/linux/mmzone.h~wait_table-and-zonelist-initializing-for-memory-hotadd-change-name-of-wait_table_size include/linux/mmzone.h --- a/include/linux/mmzone.h~wait_table-and-zonelist-initializing-for-memory-hotadd-change-name-of-wait_table_size +++ a/include/linux/mmzone.h @@ -197,7 +197,7 @@ struct zone { /* * wait_table -- the array holding the hash table - * wait_table_size -- the size of the hash table array + * wait_table_hash_nr_entries -- the size of the hash table array * wait_table_bits -- wait_table_size == (1 << wait_table_bits) * * The purpose of all these is to keep track of the people @@ -220,7 +220,7 @@ struct zone { * free_area_init_core() performs the initialization of them. */ wait_queue_head_t * wait_table; - unsigned long wait_table_size; + unsigned long wait_table_hash_nr_entries; unsigned long wait_table_bits; /* diff -puN mm/page_alloc.c~wait_table-and-zonelist-initializing-for-memory-hotadd-change-name-of-wait_table_size mm/page_alloc.c --- a/mm/page_alloc.c~wait_table-and-zonelist-initializing-for-memory-hotadd-change-name-of-wait_table_size +++ a/mm/page_alloc.c @@ -1727,7 +1727,7 @@ void __init build_all_zonelists(void) */ #define PAGES_PER_WAITQUEUE 256 -static inline unsigned long wait_table_size(unsigned long pages) +static inline unsigned long wait_table_hash_nr_entries(unsigned long pages) { unsigned long size = 1; @@ -2019,13 +2019,15 @@ void zone_wait_table_init(struct zone *z * The per-page waitqueue mechanism uses hashed waitqueues * per zone. */ - zone->wait_table_size = wait_table_size(zone_size_pages); - zone->wait_table_bits = wait_table_bits(zone->wait_table_size); + zone->wait_table_hash_nr_entries = + wait_table_hash_nr_entries(zone_size_pages); + zone->wait_table_bits = + wait_table_bits(zone->wait_table_hash_nr_entries); zone->wait_table = (wait_queue_head_t *) - alloc_bootmem_node(pgdat, zone->wait_table_size + alloc_bootmem_node(pgdat, zone->wait_table_hash_nr_entries * sizeof(wait_queue_head_t)); - for(i = 0; i < zone->wait_table_size; ++i) + for(i = 0; i < zone->wait_table_hash_nr_entries; ++i) init_waitqueue_head(zone->wait_table + i); } _ Patches currently in -mm which might be from y-goto@xxxxxxxxxxxxxx are origin.patch catch-notification-of-memory-add-event-of-acpi-via-container-driver-register-start-func-for-memory-device.patch catch-notification-of-memory-add-event-of-acpi-via-container-driveravoid-redundant-call-add_memory.patch pgdat-allocation-for-new-node-add-specify-node-id.patch pgdat-allocation-for-new-node-add-get-node-id-by-acpi.patch pgdat-allocation-for-new-node-add-generic-alloc-node_data.patch pgdat-allocation-for-new-node-add-refresh-node_data.patch pgdat-allocation-for-new-node-add-export-kswapd-start-func.patch pgdat-allocation-for-new-node-add-export-kswapd-start-func-fix.patch pgdat-allocation-for-new-node-add-call-pgdat-allocation.patch fix-compile-error-undefined-reference-for-sparc64.patch register-sysfs-file-for-hotpluged-new-node.patch pgdat-allocation-and-update-for-ia64-of-memory-hotplughold-pgdat-address-at-system-running.patch pgdat-allocation-and-update-for-ia64-of-memory-hotplug-update-pgdat-address-array.patch pgdat-allocation-and-update-for-ia64-of-memory-hotplugallocate-pgdat-and-per-node-data.patch node-hotplug-register-cpu-remove-node-struct.patch node-hotplug-register-cpu-remove-node-struct-alpha-fix.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html