The patch titled sctp_unpack_cookie() fix has been removed from the -mm tree. Its filename is sctp_unpack_cookie-fix.patch This patch was dropped because it was merged into mainline or a subsystem tree ------------------------------------------------------ Subject: sctp_unpack_cookie() fix From: Al Viro <viro@xxxxxxxxxxxxxxxx> sizeof(pointer) != sizeof(array)... Signed-off-by: Al Viro <viro@xxxxxxxxxxxxxxxxxx> Cc: Sridhar Samudrala <sri@xxxxxxxxxx> Cc: "David S. Miller" <davem@xxxxxxxxxxxxx> Signed-off-by: Andrew Morton <akpm@xxxxxxxx> --- net/sctp/sm_make_chunk.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff -puN net/sctp/sm_make_chunk.c~sctp_unpack_cookie-fix net/sctp/sm_make_chunk.c --- a/net/sctp/sm_make_chunk.c~sctp_unpack_cookie-fix +++ a/net/sctp/sm_make_chunk.c @@ -1402,14 +1402,14 @@ struct sctp_association *sctp_unpack_coo sg.length = bodysize; key = (char *)ep->secret_key[ep->current_key]; - memset(digest, 0x00, sizeof(digest)); + memset(digest, 0x00, SCTP_SIGNATURE_SIZE); sctp_crypto_hmac(sctp_sk(ep->base.sk)->hmac, key, &keylen, &sg, 1, digest); if (memcmp(digest, cookie->signature, SCTP_SIGNATURE_SIZE)) { /* Try the previous key. */ key = (char *)ep->secret_key[ep->last_key]; - memset(digest, 0x00, sizeof(digest)); + memset(digest, 0x00, SCTP_SIGNATURE_SIZE); sctp_crypto_hmac(sctp_sk(ep->base.sk)->hmac, key, &keylen, &sg, 1, digest); _ Patches currently in -mm which might be from viro@xxxxxxxxxxxxxxxx are sparc-build-breakage.patch kill-open-coded-offsetof-in-cm4000_csc-zero_dev.patch m68k-trapsc-constraints.patch m68k-windfarm-is-powerpc-only-dont-do-it-on-m68k-macs.patch affs_fill_super-%s-abuses-2.patch slab-leaks3-default-y.patch - To unsubscribe from this list: send the line "unsubscribe mm-commits" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html