Hi Geert, > > Great, so MIPS defines PC, precluding it use in any driver that includes > > <asm/ptrace.h> in some way. That really stinks!!! > Anyway, drivers//pinctrl/pinctrl-rza2.c doesn't really use the enum > values it defines, > so they can be renamed (PC -> PORTC, or PORT_C). Of course that means I have to go back and change everything to PORTx. :( Damn you MIPS!!!!! Chris On Wednesday, November 07, 2018, Geert Uytterhoeven wrote: > On Wed, Nov 7, 2018 at 10:22 AM Geert Uytterhoeven <geert@xxxxxxxxxxxxxx> > wrote: > > On Wed, Nov 7, 2018 at 10:12 AM kbuild test robot <lkp@xxxxxxxxx> wrote: > > > tree: https://git.kernel.org/pub/scm/linux/kernel/git/geert/renesas- > drivers.git topic/pinctrl-rza2-v2 > > > head: bb0f488fb2907f47250f7f34af60a482fd3dbfe4 > > > commit: feac9e8cb1ad7b4979e4b553fcdf2d8582049227 [1/2] pinctrl: Add > RZ/A2 pin and gpio controller > > > config: mips-allmodconfig (attached as .config) > > > compiler: mips-linux-gnu-gcc (Debian 7.2.0-11) 7.2.0 > > > reproduce: > > > wget https://raw.githubusercontent.com/intel/lkp- > tests/master/sbin/make.cross -O ~/bin/make.cross > > > chmod +x ~/bin/make.cross > > > git checkout feac9e8cb1ad7b4979e4b553fcdf2d8582049227 > > > # save the attached .config to linux build tree > > > GCC_VERSION=7.2.0 make.cross ARCH=mips > > > > > > All error/warnings (new ones prefixed by >>): > > > > > > In file included from arch/mips/include/asm/ptrace.h:19:0, > > > from include/linux/irq.h:24, > > > from include/linux/gpio/driver.h:7, > > > from include/asm-generic/gpio.h:13, > > > from include/linux/gpio.h:62, > > > from drivers//pinctrl/pinctrl-rza2.c:14: > > > >> arch/mips/include/uapi/asm/ptrace.h:17:13: error: expected > identifier before numeric constant > > > #define PC 64 > > > ^ > > > > Great, so MIPS defines PC, precluding it use in any driver that includes > > <asm/ptrace.h> in some way. > > > > However, it looks like <linux/gpio/driver.h> doesn't really need > <linux/irq.h>. > > Will send a patch to try that... > > Doesn't work, as it also includes <irqchip/chained_irq.h>, which is needed. > > Anyway, drivers//pinctrl/pinctrl-rza2.c doesn't really use the enum > values it defines, > so they can be renamed (PC -> PORTC, or PORT_C). > > Gr{oetje,eeting}s, > > Geert > > -- > Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux- > m68k.org > > In personal conversations with technical people, I call myself a hacker. > But > when I'm talking to journalists I just say "programmer" or something like > that. > -- Linus Torvalds