Hi Linus, On Sat, May 26, 2018 at 07:12:51PM +0200, Linus Walleij wrote: > I used bad names in my clumsiness when rewriting many board > files to use GPIO descriptors instead of platform data. A few > had the platform_device ID set to -1 which would indeed give > the device name "i2c-gpio". > > But several had it set to >=0 which gives the names > "i2c-gpio.0", "i2c-gpio.1" ... > > Fix the one affected board in the MIPS tree. Sorry. Reviewed-by: Paul Burton <paul.burton@xxxxxxxx> Thanks, Paul > Fixes: b2e63555592f ("i2c: gpio: Convert to use descriptors") > Cc: Ralf Baechle <ralf@xxxxxxxxxxxxxx> > Cc: Wolfram Sang <wsa@xxxxxxxxxxxxx> > Cc: Simon Guinot <simon.guinot@xxxxxxxxxxxx> > Reported-by: Simon Guinot <simon.guinot@xxxxxxxxxxxx> > Signed-off-by: Linus Walleij <linus.walleij@xxxxxxxxxx> > --- > Ralf can you please apply this for MIPS fixes? > --- > arch/mips/ath79/mach-pb44.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/mips/ath79/mach-pb44.c b/arch/mips/ath79/mach-pb44.c > index 6b2c6f3baefa..75fb96ca61db 100644 > --- a/arch/mips/ath79/mach-pb44.c > +++ b/arch/mips/ath79/mach-pb44.c > @@ -34,7 +34,7 @@ > #define PB44_KEYS_DEBOUNCE_INTERVAL (3 * PB44_KEYS_POLL_INTERVAL) > > static struct gpiod_lookup_table pb44_i2c_gpiod_table = { > - .dev_id = "i2c-gpio", > + .dev_id = "i2c-gpio.0", > .table = { > GPIO_LOOKUP_IDX("ath79-gpio", PB44_GPIO_I2C_SDA, > NULL, 0, GPIO_ACTIVE_HIGH | GPIO_OPEN_DRAIN), > -- > 2.17.0 > >