From: Nicholas Mc Guire <hofrat@xxxxxxxxx> commit ed9244e6c534612d2b5ae47feab2f55a0d4b4ced upstream. Fix possible unintended sign extension in unsigned MMIO loads by casting to uint16_t in the case of mmio_needed != 2. Signed-off-by: Nicholas Mc Guire <hofrat@xxxxxxxxx> Reviewed-by: James Hogan <james.hogan@xxxxxxxxxx> Tested-by: James Hogan <james.hogan@xxxxxxxxxx> Cc: Gleb Natapov <gleb@xxxxxxxxxx> Cc: Paolo Bonzini <pbonzini@xxxxxxxxxx> Cc: kvm@xxxxxxxxxxxxxxx Cc: linux-mips@xxxxxxxxxxxxxx Cc: linux-kernel@xxxxxxxxxxxxxxx Patchwork: https://patchwork.linux-mips.org/patch/9985/ Signed-off-by: Ralf Baechle <ralf@xxxxxxxxxxxxxx> Cc: <stable@xxxxxxxxxxxxxxx> # v3.10+ Signed-off-by: James Hogan <james.hogan@xxxxxxxxxx> --- This is a trivial backport (i.e. git cherry-pick, git format-patch) for stable branches before v3.17, due to the commit d7d5b05faf16 ("MIPS: KVM: Rename files to remove the prefix "kvm_" and "kvm_mips_"") which renamed a bunch of files including this one. --- arch/mips/kvm/kvm_mips_emul.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/arch/mips/kvm/kvm_mips_emul.c b/arch/mips/kvm/kvm_mips_emul.c index e75ef8219caf..c76f297b7149 100644 --- a/arch/mips/kvm/kvm_mips_emul.c +++ b/arch/mips/kvm/kvm_mips_emul.c @@ -1626,7 +1626,7 @@ kvm_mips_complete_mmio_load(struct kvm_vcpu *vcpu, struct kvm_run *run) if (vcpu->mmio_needed == 2) *gpr = *(int16_t *) run->mmio.data; else - *gpr = *(int16_t *) run->mmio.data; + *gpr = *(uint16_t *)run->mmio.data; break; case 1: -- 2.3.6