On Wednesday 29 October 2014 21:16:58 Brian Norris wrote: > > static int is_big_endian(struct irq_chip_generic *gc) > > { > > - return !!(gc->domain->gc->gc_flags & IRQ_GC_BE_IO); > > + if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP) && > > + !IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE)) > > + return 0; > > + else if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE) && > > + !IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP)) > > + return 1; > > Would XOR make this any easier to read? e.g.: > > if (IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP) ^ > IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE)) > return IS_ENABLED(CONFIG_GENERIC_IRQ_CHIP_BE); > else > ... > I think that would only be easier to read for the compiler, not for for a human. ;-) Arnd