This patch-set contains patches to clean up the recently introduced code for the AR724X PCI controller. This is required to allow to add support for the AR71XX PCI controller. Changes since v4: -fix build failure if PCI support is disabled. Gabor Juhos (7): MIPS: ath79: separate common PCI code MIPS: ath79: rename pci-ath724x.h MIPS: ath79: make ath724x_pcibios_init visible for external code MIPS: ath79: add a common PCI registration function MIPS: ath79: rename pci-ath724x.c to make it reflect the real SoC name MIPS: ath79: replace ath724x to ar724x MIPS: ath79: use io-accessor macros in pci-ar724x.c arch/mips/ath79/Makefile | 1 + arch/mips/ath79/mach-ubnt-xm.c | 7 +- arch/mips/ath79/pci.c | 56 +++++++ .../asm/mach-ath79/pci-ath724x.h => ath79/pci.h} | 16 ++- .../asm/mach-ath79/{pci-ath724x.h => pci.h} | 17 +- arch/mips/pci/Makefile | 2 +- arch/mips/pci/pci-ar724x.c | 149 +++++++++++++++++ arch/mips/pci/pci-ath724x.c | 174 -------------------- 8 files changed, 230 insertions(+), 192 deletions(-) create mode 100644 arch/mips/ath79/pci.c copy arch/mips/{include/asm/mach-ath79/pci-ath724x.h => ath79/pci.h} (53%) rename arch/mips/include/asm/mach-ath79/{pci-ath724x.h => pci.h} (53%) create mode 100644 arch/mips/pci/pci-ar724x.c delete mode 100644 arch/mips/pci/pci-ath724x.c -- 1.7.2.1