Kevin Cernekee reported that recent cleanup that replaced pci_iomap with a generic function failed to take into account the differences in io port handling on mips and sh architectures. Rather than revert the changes reintroducing the code duplication, this patchset fixes this by adding ability for architectures to override ioport mapping for pci devices. I put this in my tree that feeds into linux-next and intend to ask Linus to pull this fix if this doesn't cause any issues and there are no objections. The patches were tested on x86 and compiled on mips and sh. Would appreciate reviews/acks/testing reports. Michael S. Tsirkin (3): lib: add NO_GENERIC_PCI_IOPORT_MAP mips: use the the PCI controller's io_map_base sh: use the the PCI channels's io_map_base arch/mips/Kconfig | 1 + arch/mips/lib/iomap-pci.c | 4 ++-- arch/sh/Kconfig | 1 + arch/sh/drivers/pci/pci.c | 4 ++-- include/asm-generic/pci_iomap.h | 5 +++++ lib/Kconfig | 3 +++ lib/pci_iomap.c | 12 +++++++++++- 7 files changed, 25 insertions(+), 5 deletions(-) -- 1.7.8.2.325.g247f9