[PATCH v3 0/7] MIPS: ath79: cleanup AR724X PCI support code

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This patch-set contains patches to clean up the recently 
introduced code for the AR724X PCI controller. This is required
allow to add support for the AR71XX PCI controller. 

Gabor Juhos (7):
  MIPS: ath79: separate common PCI code
  MIPS: ath79: rename pci-ath724x.h
  MIPS: ath79: make ath724x_pcibios_init visible for external code
  MIPS: ath79: add a common PCI registration function
  MIPS: ath79: rename pci-ath724x.c to make it reflect the real SoC name
  MIPS: ath79: replace ath724x to ar724x
  MIPS: ath79: use io-accessor macros in pci-ar724x.c

 arch/mips/ath79/Makefile                       |    1 +
 arch/mips/ath79/mach-ubnt-xm.c                 |    7 +-
 arch/mips/ath79/pci.c                          |   60 ++++++++
 arch/mips/ath79/pci.h                          |   27 ++++
 arch/mips/include/asm/mach-ath79/pci-ath724x.h |   21 ---
 arch/mips/include/asm/mach-ath79/pci.h         |   20 +++
 arch/mips/pci/Makefile                         |    2 +-
 arch/mips/pci/pci-ar724x.c                     |  149 ++++++++++++++++++++
 arch/mips/pci/pci-ath724x.c                    |  174 ------------------------
 9 files changed, 262 insertions(+), 199 deletions(-)
 create mode 100644 arch/mips/ath79/pci.c
 create mode 100644 arch/mips/ath79/pci.h
 delete mode 100644 arch/mips/include/asm/mach-ath79/pci-ath724x.h
 create mode 100644 arch/mips/include/asm/mach-ath79/pci.h
 create mode 100644 arch/mips/pci/pci-ar724x.c
 delete mode 100644 arch/mips/pci/pci-ath724x.c

-- 
1.7.2.1




[Index of Archives]     [Linux MIPS Home]     [LKML Archive]     [Linux ARM Kernel]     [Linux ARM]     [Linux]     [Git]     [Yosemite News]     [Linux SCSI]     [Linux Hams]

  Powered by Linux