2011/6/6 Hauke Mehrtens <hauke@xxxxxxxxxx>: > +config BCMA_PCICORE_HOSTMODE > + Â Â Â bool "Hostmode support for BCMA PCI core" > + Â Â Â depends on BCMA_DRIVER_MIPS > + Â Â Â help > + Â Â Â Â PCIcore hostmode operation (external PCI bus). I think you started to use BCMA_DRIVER_corename. Could you stick to it (one schema), please? Maybe just BCMA_DRIVER_PCI_HOSTMODE ? > +#ifdef CONFIG_BCMA_PCICORE_HOSTMODE > + Â Â Â pc->hostmode = bcma_pcicore_is_in_hostmode(pc); > + Â Â Â if (pc->hostmode) > + Â Â Â Â Â Â Â bcma_pcicore_init_hostmode(pc); > +#endif /* CONFIG_BCMA_PCICORE_HOSTMODE */ > + Â Â Â if (!pc->hostmode) > + Â Â Â Â Â Â Â bcma_pcicore_serdes_workaround(pc); Does it make sense to init hostmode PCI like clientmode if we just disable CONFIG_BCMA_PCICORE_HOSTMODE? I think we should always check if core is host or client mode and use correct initialization only. We should not init it as clientmode just because we do not have driver for host mode. > diff --git a/drivers/bcma/driver_pci_host.c b/drivers/bcma/driver_pci_host.c > new file mode 100644 > index 0000000..b52c6c9 > --- /dev/null > +++ b/drivers/bcma/driver_pci_host.c > @@ -0,0 +1,44 @@ > +/* > + * Broadcom specific AMBA > + * PCI Core Please rename "PCI Core", add something about hostmode. -- RafaÅ