On 01/21/2010 07:21 PM, Wu Fengguang wrote: > --- linux-mm.orig/kernel/resource.c 2010-01-22 11:20:34.000000000 +0800 > +++ linux-mm/kernel/resource.c 2010-01-22 11:20:35.000000000 +0800 > @@ -327,6 +327,17 @@ int walk_system_ram_range(unsigned long > > #endif > > +#define PAGE_IS_RAM 24 > +static int __is_ram(unsigned long pfn, unsigned long nr_pages, void *arg) > +{ > + return PAGE_IS_RAM; > +} > +int __attribute__((weak)) page_is_ram(unsigned long pfn) > +{ > + return PAGE_IS_RAM == walk_system_ram_range(pfn, 1, NULL, __is_ram); > +} > +#undef PAGE_IS_RAM > + Stylistic nitpick: The use of the magic number "24" here is pretty ugly; it seems to imply that there is something peculiar with this number and that it is trying to avoid an overlap, whereas in fact any number but 0 and -1 would do. I would rather see just returning 1 and do: return walk_system_ram_range(pfn, 1, NULL, __is_ram) == 1; (walk_system_ram_range() returning -1 on error, and 0 means continue.) Note also that we don't write "constant == expression"; although some schools teach it as a way to avoid the "=" versus "==" beginner C mistake, it makes the code less intuitive to read. Other than that, the patchset looks good; if Ingo doesn't beat me to it I'll put it in tomorrow (need sleep right now.) -hpa -- H. Peter Anvin, Intel Open Source Technology Center I work for Intel. I don't speak on their behalf.