Re: [PATCH 10/10] bcm63xx: clarify meaning of the magical value in ehci-bcm63xx.c

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Le Monday 01 June 2009 19:21:58 Maxime Bizon, vous avez écrit :
> USB maintainer asked for clarification of the magic value used during
> USB init. Be clear about the source of it.
>
> Signed-off-by: Maxime Bizon <mbizon@xxxxxxxxxx>

Acked-by: Florian Fainelli <florian@xxxxxxxxxxx>

> ---
>  drivers/usb/host/ehci-bcm63xx.c |    4 +++-
>  1 files changed, 3 insertions(+), 1 deletions(-)
>
> diff --git a/drivers/usb/host/ehci-bcm63xx.c
> b/drivers/usb/host/ehci-bcm63xx.c index 8a62c0a..5a03fdd 100644
> --- a/drivers/usb/host/ehci-bcm63xx.c
> +++ b/drivers/usb/host/ehci-bcm63xx.c
> @@ -78,7 +78,9 @@ static int __devinit ehci_hcd_bcm63xx_drv_probe(struct
> platform_device *pdev) reg |= USBH_PRIV_SWAP_EHCI_ENDN_MASK;
>  	bcm_rset_writel(RSET_USBH_PRIV, reg, USBH_PRIV_SWAP_REG);
>
> -	/* don't ask... */
> +	/* the magic value comes for the original vendor BSP and is
> +	 * needed for USB to work. Datasheet does not help, so the
> +	 * magic value is used as-is. */
>  	bcm_rset_writel(RSET_USBH_PRIV, 0x1c0020, USBH_PRIV_TEST_REG);
>
>  	hcd = usb_create_hcd(&ehci_bcm63xx_hc_driver, &pdev->dev, "bcm63xx");



-- 
Best regards, Florian Fainelli
Email : florian@xxxxxxxxxxx
http://openwrt.org
-------------------------------


[Index of Archives]     [Linux MIPS Home]     [LKML Archive]     [Linux ARM Kernel]     [Linux ARM]     [Linux]     [Git]     [Yosemite News]     [Linux SCSI]     [Linux Hams]

  Powered by Linux