Hi Ralf, Ralf Baechle wrote:
Time to send bring this to a larger audience. I'm working on getting dyntick and highres timer support working for MIPS. This unavoidably implies dumping most of the MIPS-private time infrastructure we've piled up over the past decade. Which really is a major crapectomy. A first cut of the patches which are tested to run
That's definitely true. I wrote my own version of clockevent support yesterday based on your patchset "dyntick-quilt" and I end up rewrite the whole time.c. The biggest part of the job would be to split this into several patches to ease the review but I doubt it worth it since we rewrite it almost from scratch. Another issue I have is to implement clockevent set_mode() method. You left it empty but I think we need at least to shut down the timer interrupt when setting the clock event device. Strangely I haven't found a "generic" way to stop them through cp0. Have I missed something ? If not, that would mean that either we need a new hook to achieve that or we find a way/hack to do that in a mips generic way. Advice on this point would be appreciated.
well on uniprocessor and VSMP Malta kernels is at:
ftp://ftp.linux-mips.org/pub/linux/mips/people/ralf/dyntick-quilt It will also likely work on various other simple systems. A more recent version of these patches which I haven't yet gotten around to test on silicon is available at: ftp://ftp.linux-mips.org/pub/linux/mips/people/ralf/linux-time.patches
BTW any idea when "time-ntp-make-cmos-update-generic.patch" is going to be merged into mainline ? Note: I think there's a bug in notify_cmos_timer(). The following test should be negated, shouldn't it ? + if (no_sync_cmos_clock) + mod_timer(&sync_cmos_timer, jiffies + 1); The other patch named "time-move-to_tm-to-lib.patch" create a new file in arch/mips/lib directory. This new file is called "to_tm.c". Shouldn't we call it something less specific like "time.c" ? -- Franck