Changes since take #3 -------------------- * Sign extension hack still needed by rd_start_early() (Atsushi) * Replace panic() by printk() in init_initrd() (Atsushi) * Fix CONFIG_64BITS typo (Atsushi) * Add a new sanity check in init_initrd(): initrd_start < PAGE_OFFSET Changes since take #2 -------------------- * More initrd code clean up. It should be more readable and more robust now. * Add some missing include in page.h (Atsushi) * Fix a wrong use of __page_offset() in __va() (Atsushi) * Rename __page_offset() into __pa_page_offset() changes since take #1 -------------------- * Changed the definition of __pa() for 64-bits kernels to match the one suggested by Atsushi. It should be safer. * Make virt_to_page() uses virt_to_phys() instead of __pa(). Thanks to Atsushi for testing this patchset on 64 bit kernels. Please consider, Franck --- arch/mips/kernel/setup.c | 87 +++++++++++++++++++++++++++----------------- arch/mips/mm/init.c | 42 ++++++++++----------- include/asm-mips/io.h | 2 + include/asm-mips/page.h | 16 ++++++-- include/asm-mips/pgtable.h | 2 + 5 files changed, 87 insertions(+), 62 deletions(-)