Atsushi Nemoto wrote: > On Wed, 9 Aug 2006 16:52:34 +0200, Franck Bui-Huu <vagabon.xyz@xxxxxxxxx> wrote: >> + unsigned long initrd_size = >> + (unsigned long)initrd_end - (unsigned long)initrd_start; > > While initrd_end and initrd_start are unsigned long, these casts are > redundant. > Absolutely. I don't remember why I added these useless casts... >> + printk(KERN_INFO "Initial ramdisk at: 0x%p (%lu bytes)\n", >> + (void *)initrd_start, initrd_size); > > You can use "0x%lx" for initrd_start and remove the cast. I know this > fragment are copied from corrent code as is, but it would be a good > chance to clean it up. > You're right. I'll change that and make a take #3. Thanks for your comments. Franck