Re: [PATCH 1/7] Make get_frame_info() more readable.

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue,  1 Aug 2006 11:27:11 +0200, Franck Bui-Huu <vagabon.xyz@xxxxxxxxx> wrote:
> +static inline int is_ra_save_ins(union mips_instruction *pc)
> +{
> +	/* sw / sd $ra, offset($sp) */
> +	return (pc->i_format.opcode == sw_op || pc->i_format.opcode == sd_op) &&
> +		pc->i_format.rs == 29 &&
> +		pc->i_format.rt == 31;
> +}

Separating these function would be good, but let's play with 80
columns rule.

---
Atsushi Nemoto


[Index of Archives]     [Linux MIPS Home]     [LKML Archive]     [Linux ARM Kernel]     [Linux ARM]     [Linux]     [Git]     [Yosemite News]     [Linux SCSI]     [Linux Hams]

  Powered by Linux