Atsushi Nemoto wrote: > > Subject: [PATCH] make get_frame_info() more readable. > > Signed-off-by: Atsushi Nemoto <anemo@xxxxxxxxxxxxx> > > diff --git a/arch/mips/kernel/process.c b/arch/mips/kernel/process.c > index 8709a46..949efaf 100644 > --- a/arch/mips/kernel/process.c > +++ b/arch/mips/kernel/process.c > @@ -286,18 +286,17 @@ static int get_frame_info(struct mips_fr > int i; > void *func = info->func; > union mips_instruction *ip = (union mips_instruction *)func; while you're at it, (union mips_instruction *) cast is useless and "func" local too. Just write union mips_instruction *ip = info->func; is more readable, IMHO. Franck