>>>>> "maciej" == Maciej W Rozycki <macro@ds2.pg.gda.pl> writes: maciej> On 18 Dec 2002, Juan Quintela wrote: >> +#ifdef CONFIG_HIGHMEM >> unsigned long vaddr; >> - pgd_t *pgd, *pgd_base; >> pmd_t *pmd; >> pte_t *pte; >> - >> + pgd_t *pgd, pgd_base; >> +#endif >> /* Initialize the entire pgd. */ >> pgd_init((unsigned long)swapper_pg_dir); maciej> Please don't change the spacing this way -- it worsens readability. maciej> Check other pathes for cases like this, too. Hi Argh, the patch indeed missed an *. What do you think of this new one? Later ,Juan. Index: arch/mips/mm/init.c =================================================================== RCS file: /home/cvs/linux/arch/mips/mm/init.c,v retrieving revision 1.38.2.7 diff -u -r1.38.2.7 init.c --- arch/mips/mm/init.c 5 Aug 2002 23:53:35 -0000 1.38.2.7 +++ arch/mips/mm/init.c 19 Dec 2002 09:21:09 -0000 @@ -161,6 +161,7 @@ extern char _ftext, _etext, _fdata, _edata; extern char __init_begin, __init_end; +#ifdef CONFIG_HIGHMEM static void __init fixrange_init (unsigned long start, unsigned long end, pgd_t *pgd_base) { @@ -189,22 +190,26 @@ j = 0; } } +#endif /* CONFIG_HIGHMEM */ void __init pagetable_init(void) { +#ifdef CONFIG_HIGHMEM unsigned long vaddr; pgd_t *pgd, *pgd_base; pmd_t *pmd; pte_t *pte; +#endif /* Initialize the entire pgd. */ pgd_init((unsigned long)swapper_pg_dir); pgd_init((unsigned long)swapper_pg_dir + sizeof(pgd_t ) * USER_PTRS_PER_PGD); - pgd_base = swapper_pg_dir; #ifdef CONFIG_HIGHMEM + pgd_base = swapper_pg_dir; + /* * Fixed mappings: */ -- In theory, practice and theory are the same, but in practice they are different -- Larry McVoy