On Mon, Jul 15, 2019 at 09:57:03AM +0200, Pablo Neira Ayuso wrote: > On Fri, Jul 12, 2019 at 09:07:21PM +0800, yangxingwu wrote: > > this patch removes the extra space and use bitmap_zalloc instead > > > > Signed-off-by: yangxingwu <xingwu.yang@xxxxxxxxx> > > --- > > net/netfilter/ipvs/ip_vs_mh.c | 3 +-- > > 1 file changed, 1 insertion(+), 2 deletions(-) > > > > diff --git a/net/netfilter/ipvs/ip_vs_mh.c b/net/netfilter/ipvs/ip_vs_mh.c > > index 94d9d34..3229867 100644 > > --- a/net/netfilter/ipvs/ip_vs_mh.c > > +++ b/net/netfilter/ipvs/ip_vs_mh.c > > @@ -174,8 +174,7 @@ static int ip_vs_mh_populate(struct ip_vs_mh_state *s, > > return 0; > > } > > > > - table = kcalloc(BITS_TO_LONGS(IP_VS_MH_TAB_SIZE), > > - sizeof(unsigned long), GFP_KERNEL); > > + table = bitmap_zalloc(IP_VS_MH_TAB_SIZE, GFP_KERNEL); > > By doing: > > git grep "= " ... > > on the netfilter folders, I see more of these, it would be good if you > fix them at once or, probably, you want to use coccinelle for this. If patch subject is "remove unnecessary space" then just remove unnecessary spaces in the patch, otherwise I suggest you rename this to "ipvs: use bitmap_zalloc()" or such, since the space removal here is irrelevant.