On Tue, Mar 28, 2017 at 7:24 PM, Jan Engelhardt <jengelh@xxxxxxx> wrote: > On Tuesday 2017-03-28 15:13, simran singhal wrote: > >>Some functions like kmalloc/kzalloc return NULL on failure. When NULL >>represents failure, !x is commonly used. >> >>@@ -910,7 +910,7 @@ ip_vs_new_dest(struct ip_vs_service *svc, struct ip_vs_dest_user_kern *udest, >> } >> >> dest = kzalloc(sizeof(struct ip_vs_dest), GFP_KERNEL); >>- if (dest == NULL) >>+ if (!dest) >> return -ENOMEM; > > This kind of transformation however is not cleanup anymore, it's really > bikeshedding and should be avoided. There are pro and cons for both > variants, and there is not really an overwhelming number of arguments > for either variant to justify the change. Sorry, but I didn't get what you are trying to convey. And particularly pros and cons of both variants. -- To unsubscribe from this list: send the line "unsubscribe lvs-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html