Re: [PATCH] hwmon: Add support for MAX6642

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Mar 31, 2011 at 8:34 PM, Per DalÃn <per.dalen@xxxxxxxxxxxx> wrote:
> MAX6642 is a SMBus-Compatible Remote/Local Temperature Sensor with
> Overtemperature Alarm from Maxim.

Hello,
I've just a couple of minor comments:

[...]
> +struct max6642_data {
> + Â Â Â struct device *hwmon_dev;
> + Â Â Â struct mutex update_lock;
> + Â Â Â char valid; /* zero until following fields are valid */

I'd use bool instead of char

> + Â Â Â unsigned long last_updated; /* in jiffies */
> +
> + Â Â Â /* registers values */
> + Â Â Â u16 temp_input1, temp_high1; /* local */
> + Â Â Â u16 temp_input2, temp_high2; /* remote */

IMHO keeping one field declaration per line makes it more readable.

>From a quick glance the rest looks fine.

Luca

_______________________________________________
lm-sensors mailing list
lm-sensors@xxxxxxxxxxxxxx
http://lists.lm-sensors.org/mailman/listinfo/lm-sensors



[Index of Archives]     [Linux Kernel]     [Linux Hardware Monitoring]     [Linux USB Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [Yosemite Backpacking]

  Powered by Linux