On Mon, 27 Jul 2009 21:46:14 +0100, Mark Brown wrote: > On Mon, Jul 27, 2009 at 09:44:19PM +0200, Jean Delvare wrote: > > On Mon, 27 Jul 2009 14:46:02 +0100, Mark Brown wrote: > > > +#define WM831X_NAMED_VOLTAGE(id, name) \ > > > + static SENSOR_DEVICE_ATTR(in##id##_input, S_IRUGO, show_voltage,\ > > > + NULL, name); \ > > > > I guess you could just call WM831X_VOLTAGE(id, name). > > That clashes with the unnamed voltage above. I could also call them > _NAMED and _UNNAMED, I suppose. Sorry for not being clear. I simply meant you could write the following: define WM831X_VOLTAGE(id, name) \ static SENSOR_DEVICE_ATTR(in##id##_input, S_IRUGO, show_voltage, \ NULL, name) #define WM831X_NAMED_VOLTAGE(id, name) \ WM831X_VOLTAGE(id, name); \ static SENSOR_DEVICE_ATTR(in##id##_label, S_IRUGO, show_label, \ NULL, name) Which makes it more obvious that WM831X_NAMED_VOLTAGE is WM831X_VOLTAGE + label. But it's really up to you which way you prefer. -- Jean Delvare