On Tue, 2008-11-11 at 09:07 -0800, Andrew Morton wrote: > On Tue, 11 Nov 2008 11:04:54 +0100 Jean Delvare <khali at linux-fr.org> wrote: > > On Mon, 10 Nov 2008 17:01:32 -0800, Darrick J. Wong wrote: > > > diff --git a/include/linux/kernel.h b/include/linux/kernel.h > > > index fba141d..fb02266 100644 > > > --- a/include/linux/kernel.h > > > +++ b/include/linux/kernel.h > > > @@ -48,6 +48,12 @@ extern const char linux_proc_banner[]; > > > #define FIELD_SIZEOF(t, f) (sizeof(((t*)0)->f)) > > > #define DIV_ROUND_UP(n,d) (((n) + (d) - 1) / (d)) > > > #define roundup(x, y) ((((x) + ((y) - 1)) / (y)) * (y)) > > > +#define DIV_ROUND_CLOSEST(x, divisor)( \ > > > +{ \ > > > + typeof(divisor) __divisor = divisor; \ > > > + (((x) + ((__divisor) / 2)) / (__divisor)); \ > > > +} \ > > > +) > > I don't get why you implement this as a macro rather than an inline > > function? A function would look much better. > The idea is that DIV_ROUND_CLOSEST() can be used with arguments of any > size (char, short, ... long long) and will do all the suitable > promotion and will return a type of the appropriate width and > signedness. Perhaps the macro should be placed directly after DIV_ROUND_UP and should use the same argument naming. Perhaps HALF_UP is more descriptive and fairly common. http://java.sun.com/j2se/1.5.0/docs/api/java/math/RoundingMode.html