Jean Delvare wrote: > Hi Jim, > > > again, respun per your comments. > >> -#define W83781D_REG_FAN_MIN(nr) (0x3a + (nr)) >> -#define W83781D_REG_FAN(nr) (0x27 + (nr)) >> +#define W83781D_REG_FAN_MIN(nr) (0x3b + (nr)) >> +#define W83781D_REG_FAN(nr) (0x28 + (nr)) >> > > Here again, please rename these W83627HF_* while you're here. Maybe > also tab-align the definitions for readability. I would also appreciate > a comment giving the valid values of nr, just to clear up any possible > confusion. > > Done. >> + for (i = 0; i <= 2; i++) >> + data->fan_min[i] = >> + w83627hf_read_value(data, W83781D_REG_FAN_MIN(i)); >> > > At this point your patch conflicts with one I sent a few days ago: > hwmon: (w83627hf) Fix setting fan min right after driver load > http://lm-sensors.org/kernel?p=kernel/mhoffman/hwmon-2.6.git;a=commitdiff;h=c09c5184a26158da32801e89d5849d774605f0dd > > Please make sure you have this patch applied on your local tree before > regenerating and resending your patch. > > Yup. done. > Rest looks OK and testing is OK as well. > > Thanks, > -------------- next part -------------- An embedded and charset-unspecified text was scrubbed... Name: diff.hwmon-w83627hf-fan-offset-into-macro Url: http://lists.lm-sensors.org/pipermail/lm-sensors/attachments/20071014/a697ef38/attachment.pl