On Thu, Jun 10, 2004 at 12:32:08PM -0700, Greg KH wrote: > On Thu, Jun 10, 2004 at 08:14:00PM +0100, viro at parcelfarce.linux.theplanet.co.uk wrote: > > On Thu, Jun 10, 2004 at 12:10:04PM -0700, Greg KH wrote: > > > @@ -170,8 +170,11 @@ > > > static int DIV_TO_REG(int val) > > > { > > > int answer = 0; > > > - while ((val >>= 1)) > > > + val >>= 1; > > > + while (val) { > > > answer++; > > > + val >>= 1; > > > + } > > > return answer; > > > > That's less readable than the original... > > Hm, so we should ignore the sparse warning about the original then? What about: while ((val >>= 1) != 0) { ... Readable and sparse clean (I suppose). Sam