On 06/09/2017 02:38 PM, Josh Poimboeuf wrote: > On Thu, Jun 01, 2017 at 02:25:26PM -0400, Joe Lawrence wrote: >> [ ... snip ... ] >> @@ -99,6 +130,12 @@ static int livepatch_init(void) >> >> static void livepatch_exit(void) >> { >> + struct task_ctr *nd, *tmp; >> + >> + list_for_each_entry_safe(nd, tmp, &shadow_list, list) { >> + list_del(&nd->list); >> + kfree(nd); >> + } >> WARN_ON(klp_unregister_patch(&patch)); >> } > > What does 'nd' stand for? I think a name like 'ctr' would be clearer. > Ah, in an earlier draft (pre-post) that data structure was called "new_data", so "nd" was simply a short hand abbreviation. I'll update for v2, thanks. -- Joe -- To unsubscribe from this list: send the line "unsubscribe live-patching" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html