On Thu, Jun 01, 2017 at 07:40:47AM -0700, Andy Lutomirski wrote: > On Thu, Jun 1, 2017 at 7:16 AM, Josh Poimboeuf <jpoimboe@xxxxxxxxxx> wrote: > > On Thu, Jun 01, 2017 at 06:57:24AM -0700, Andy Lutomirski wrote: > >> On Wed, May 31, 2017 at 10:44 PM, Josh Poimboeuf <jpoimboe@xxxxxxxxxx> wrote: > >> > Some asm (and inline asm) code does special things to the stack which > >> > objtool can't understand. (Nor can GCC or GNU assembler, for that > >> > matter.) In such cases we need a facility for the code to provide > >> > annotations, so the unwinder can unwind through it. > >> > > >> > This provides such a facility, in the form of CFI hints. They're > >> > similar to the GNU assembler .cfi* directives, but they give more > >> > information, and are needed in far fewer places, because objtool can > >> > fill in the blanks by following branches and adjusting the stack pointer > >> > for pushes and pops. > >> > >> Two minor suggestions: > >> > >> Could you prefix these with something other than "CFI_"? For those of > >> use who have read the binutils manual, using "CFI_" sounds awfully > >> like .cfi_, and people might expect the semantics to be the same. > > > > The intention was that even if this undwarf thing doesn't work out, the > > CFI_ macros could still be used by objtool to generate proper DWARF. > > Would prefixing them with CFI_HINT_ be better? Or UNWIND_HINT_? > > This has nothing to do with the data format or implementation. I > just think that "CFI_" suggests that they're semantically equivalent > to binutils' .cfi directives. If they're not, then maybe UNWIND_HINT > is better. Ok, I'll go with the UNWIND_HINT_ prefix. -- Josh -- To unsubscribe from this list: send the line "unsubscribe live-patching" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html