On Thu, 2016-02-25 at 11:30 +1100, Balbir Singh wrote: > > On 25/02/16 01:28, Michael Ellerman wrote: > > Signed-off-by: Michael Ellerman <mpe@xxxxxxxxxxxxxx> > > > > diff --git a/arch/powerpc/kernel/entry_64.S b/arch/powerpc/kernel/entry_64.S > > index 2a7313cfbc7d..9e77a2c8f218 100644 > > --- a/arch/powerpc/kernel/entry_64.S > > +++ b/arch/powerpc/kernel/entry_64.S > > @@ -1237,6 +1237,11 @@ _GLOBAL(ftrace_graph_caller) > > std r5, 64(r1) > > std r4, 56(r1) > > std r3, 48(r1) > > + > > + /* Save callee's TOC in the ABI compliant location */ > > + std r2, 24(r1) > R2_STACK_OFFSET for readability? Hmm, maybe. Personally when I see "24(r1)" what my brain reads is "stack TOC save slot", but maybe I've been spending too much time with powerpc assembly. R2_STACK_OFFSET is actually new, pulled out from the module code by Torsten. Other code uses STK_GOT to mean the same thing. I don't really like either name, so I'll probably leave do a clean up once this is in. cheers -- To unsubscribe from this list: send the line "unsubscribe live-patching" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html