On Wed, 4 Nov 2015, Josh Poimboeuf wrote: > > > int klp_write_module_reloc(struct module *mod, unsigned long type, > > > unsigned long loc, unsigned long value) > > > { > > > - int ret, numpages, size = 4; > > > - bool readonly; > > > + int size = 4; > > > > BTW I don't see a reason to have 'size' signed here. > > It was already signed to begin with, but I can change it to size_t. Yes, I know, it's not really related to this patchset, but I stumbled upon it during review. > > > +#ifdef CONFIG_DEBUG_SET_MODULE_RONX > > > +static void set_page_attributes(void *start, void *end, > > > + int (*set)(unsigned long start, int num_pages)) > > > +{ > > > + unsigned long begin_pfn = PFN_DOWN((unsigned long)start); > > > + unsigned long end_pfn = PFN_DOWN((unsigned long)end); > > > + > > > + if (end_pfn > begin_pfn) > > > + set(begin_pfn << PAGE_SHIFT, end_pfn - begin_pfn); > > > +} BTW is there any reason not to make use of the function from module.c which does exactly the same, instead of copy pasting it all around? > > > +static void set_module_ro_rw(struct module *mod) > > > +{ > > > + set_page_attributes(mod->module_core, > > > + mod->module_core + mod->core_ro_size, > > > + set_memory_rw); > > > +} > > > +static void set_module_ro_ro(struct module *mod) > > > > Honestly, I find both the function names above horrible and not really > > self-explanatory (especially the _ro_ro variant). At least comment, > > explaining what they are actually doing, or picking up a better name, > > would make the code much more self-explanatory in my eyes. > > Being the patch author, naturally the function names make sense to me. :) > set_module_ro_ro() means "set the module's read-only area to have > read-only permissions." > > Do you have any suggestions for a better name? I'd even say it's superfluous to have the functions at the first place, and just calling set_page_attributes() directly makes the intent clear enough already. Thanks, -- Jiri Kosina SUSE Labs -- To unsubscribe from this list: send the line "unsubscribe live-patching" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html