On Wed, Feb 05, 2025 at 05:28:01PM +0100, Christoph Hellwig wrote: > Match the method name and the naming convention or address_space > operations. > > Signed-off-by: Christoph Hellwig <hch@xxxxxx> > --- > fs/xfs/xfs_aops.c | 6 +++--- > 1 file changed, 3 insertions(+), 3 deletions(-) > > diff --git a/fs/xfs/xfs_aops.c b/fs/xfs/xfs_aops.c > index c792297aa0a3..fc492a1724c3 100644 > --- a/fs/xfs/xfs_aops.c > +++ b/fs/xfs/xfs_aops.c > @@ -681,7 +681,7 @@ xfs_vm_readahead( > } > > static int > -xfs_iomap_swapfile_activate( > +xfs_vm_swap_activate( Hee hee. Reviewed-by: "Darrick J. Wong" <djwong@xxxxxxxxxx> --D > struct swap_info_struct *sis, > struct file *swap_file, > sector_t *span) > @@ -717,11 +717,11 @@ const struct address_space_operations xfs_address_space_operations = { > .migrate_folio = filemap_migrate_folio, > .is_partially_uptodate = iomap_is_partially_uptodate, > .error_remove_folio = generic_error_remove_folio, > - .swap_activate = xfs_iomap_swapfile_activate, > + .swap_activate = xfs_vm_swap_activate, > }; > > const struct address_space_operations xfs_dax_aops = { > .writepages = xfs_dax_writepages, > .dirty_folio = noop_dirty_folio, > - .swap_activate = xfs_iomap_swapfile_activate, > + .swap_activate = xfs_vm_swap_activate, > }; > -- > 2.45.2 > >